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Introduction 

How to Use this Book 

Welcome to the RISAFoundation User’s Guide. If you are a first-time user of RISAFoundation, we 
recommend that you start with this book.  

Begin by reviewing First Look at RISAFoundation on page 10 to familiarize yourself with the 
RISAFoundation menus, toolbars, and shortcuts. Appendix A – RISAFoundation Toolbar Button Quick 
Reference has also been included on page 161 to help you reference toolbar buttons. 

Following the introductory sections, notice that the book is divided into two parts: Part A and Part B, as 
described below. The two parts are independent, full tutorials, so you may go straight to the part that 
best suits your current design needs. 

Part A – Building a Model from Scratch will guide you step-by-step through the RISAFoundation 
modeling process to build and analyze a model from scratch; Part B – RISA-3D Integration will guide you 
through using RISAFoundation as integrated with RISA-3D. In each part, you will create a real-world 
example of building and solving a model, making changes, and optimizing the model. Tips and shortcuts 
will also be demonstrated along the way.  

To complete all the tutorials will take only a few hours. However, you can speed up the process even 
further if you skip the supporting text and concentrate only on the action steps, which are indicated 
with diamond-shaped bullets, as shown below: 

 In order for you to achieve accurate results, it is important that you do not miss any of these 
action steps while performing the tutorials. 

The tutorials build upon themselves from start to finish. You have the option of performing them all at 
one time, or performing each one separately. To make this possible, RISA provides model files for you to 
load at the beginning of each tutorial. These starter files are located in the RISA folder under Tutorials, 
and are named Tutorial A2 Starter.fnd, Tutorial A3 Starter.fnd, etc. 

After you have completed the tutorials in this guide, you can use the Help Menu and RISAFoundation 
General Reference for complete, detailed information on every topic relating to RISAFoundation. The 
topics are thoroughly indexed for quick reference.  

If you are a more experienced user and are not sure which book will be most helpful for your situation, 
consider that this User’s Guide covers how and when to apply RISAFoundation features such as slab 
design strips, but the specifics of how those strips effect the design of your reinforcement are covered in 
the Help Menu and the RISAFoundation General Reference.  

Where to Download RISAFoundation Book Updates 

Every effort has been made to ensure the accuracy of this book at the time of publication. The latest 
edition of all books and documents relating to this product are available in Adobe PDF format at 
http://www.risa.com. Click Downloads, Product Documentation, then RISAFoundation. 

http://www.risa.com/
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Document Conventions 

The following conventions are used throughout this book: 

This convention: Indicates: 

CAPITAL LETTERS Names of keys on the keyboard – for example, SHIFT, CTRL, or ALT. 

KEY+KEY One key should be held down and then another key pressed – for 
example, CTRL+P or ALT+F4. 

Bold text 

Boxed text 

Bulleted text 

  

User interface options – for example, File menu. 

Notes or modeling tip information. 

Action item for building the tutorial model. 

Tutorial action item for building the model. 

  



 Introduction 

3 

 

Using the Online Help 

Whether you need help on general topics, specific features, or toolbars, it is all built in to the extensive 
RISAFoundation online Help system. The RISAFoundation Help was designed to enable you to pinpoint 
the Help information you need quickly, by offering different ways for you to access and locate that Help, 
as described below: 

 

Help on  
general topics 

On the RISA toolbar, click the Help button . This is the fastest way to get 
help on general topics. You can also go to the main menu and click Help, 
then select Help Topics. 

Once you enter the Help, notice the three tabs on the left: Contents, Index, 
and Search. You can explore the Help by topic using either Contents or 
Index, or explore the Help using your own specific keywords using Search. 

 

Help on a specific 
feature (context-
sensitive help) 

As you work, notice the Help buttons at the bottom of many of the dialog 
boxes. These provide direct access to the Help information related to the 
task you are performing.  

This context-sensitive help may be accessed by pressing the Help button on 
the dialog box or by pressing the F1 key. 

 

Help on toolbar 
buttons 

Are you uncertain what a toolbar button? Simply hold your mouse pointer 
over that button (without clicking), and a description of that button will be 
displayed.  
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Technical Support Information 

Technical support is an integral part of the software packages offered by RISA Tech, Inc. and is available 
to all registered licensees at no additional charge for the life of the program. The “life of the program” is 
defined as the time period for which that version of the program is the current version or until the 
program is discontinued. In other words, whenever a new version of RISAFoundation is released, the life 
of the previous version is considered to be ended. Technical support is a limited resource; first priority 
will always be given to those clients whose licenses are current first.  

RISA Tech, Inc. will only support the current version of RISAFoundation. For a list of your support 
options, visit our website: www.risa.com/support. 

Before contacting technical support, you may want to take a few minutes to do the following: 

 Search the Help menu and all user documentation available for the product.  

 Search our FAQ database by visiting our website at http://www.risa.com. Click Support, then 
Frequently Asked Questions, and then choose RISAFoundation. 

When you are ready to make a support request, please be prepared to send us your model, and include 
the following information: 

 Your name, company name, and phone number;  

 Product name and serial number or Key ID;  

 A detailed problem description; and  

 Your model (filename.fnd) as an e-mail attachment. If your model contains multiple 
members, or load combinations, please specify which ones we should look at.  

You can contact Technical Support by e-mail or phone as follows: 

E-mail: support@risa.com 
E-mail is usually the best way to communicate with us when sending a model. Please include all the 
information listed above. 

Phone: (949) 951-5815 or (800) 332-RISA (7472) 
Technical support personnel are available from 6:00 A.M. to 5:00 P.M. Pacific Standard Time, Monday 
through Friday.  

RISA Online 

Visit RISA online at http://www.risa.com for:  

 Answers to frequently asked questions 

 Downloads of user documentation and tutorials  

 Software updates – Any known problems are posted on the website, along with possible 
work-around procedures and/or service releases to update your software 

 Software verification questions 

 

 

 

 

http://www.risa.com/support
http://www.risa.com/
mailto:support@risa.com
http://www.risa.com/
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Before You Begin 

RISAFoundation Overview 

RISAFoundation has been developed to make the definition, design, and modification of foundation 
systems fast and easy. Analysis (including calculation of deflections and stresses) may be performed on 
simple foundations or on larger multi-element foundations. Plus, element design optimization is 
provided for slabs, footings, and grade beams.  

Because of its unique ability to define the model and make revisions both graphically (using the drawing 
tools) and numerically (using the customized spreadsheets), RISAFoundation is able to significantly 
speed up the design process. 

In RISAFoundation, everything designed or drawn graphically is automatically recorded in the 
spreadsheets (which may be viewed and edited at any time)—and everything entered in the 
spreadsheets may be viewed and edited graphically at any time. The model can be rapidly edited, 
solved, viewed, modified, re-solved, etc. As you perform the step-by-step tutorials in this guide, you will 
be exploring both methods using the drawing tools and the spreadsheets. 

Hardware Requirements 

Operating System 

Subscription License 

One of the following operating systems is required: 

 Microsoft Windows 10 (64 bit only)  

 Microsoft Windows 8.1 (64 bit only)  

 Microsoft Windows 7 SP1 (64 bit only)  

Perpetual License (Standalone / Network) 

One of the following operating systems is required: 

 Microsoft Windows 10 (64 bit only) 

 Microsoft Windows 8.1 (64 bit only)  

 Microsoft Windows 7 SP1 (64 bit only) 

Hardware 
The following hardware is required: 

 1 GHz or faster processor  

 1024x768 or higher monitor resolution  

 2 (or more) button mouse, mouse wheel recommended  

 8 GB of RAM 

 4 GB of hard disk space  
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Note: The amount of space required by RISAFoundation to solve a structural model is dependent on the 
size of the model. In general, 500 MB of RAM is adequate to solve most problems, but the more the 
better, especially for large models. RISAFoundation will use as much available RAM as possible. If there 
is not enough RAM, RISAFoundation will use hard drive space until enough memory is obtained to solve 
the problem (causing the solution to run much slower). 

Program Limits 

Points 500,000 

Beams 10,000 

Materials 500 

Point Loads 250,000 

Line Loads 10,000 

Area Loads 10,000 

Load Combinations 5,000 

Slabs 250 

Soil Regions 1,000 

Design Strips 2,000 

Point Supports (Footings, Piles) 7,500 

Pile Definitions 800 

Footing Definitions 800 

Pile Cap Definitions 800 

Pedestals 7,500 

  

Demonstration Version:  You may build and solve any model, however you may not save a model. There 
are also limits on some of the design values. For example, the allowable bearing stress and subgrade 
modulus for soil can not be adjusted. 

Also, the Demonstration Version will automatically shut down if left open for 24 continuous hours.  
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License Agreement 

END-USER LICENSE AGREEMENT FOR RISA TECH, INC. SOFTWARE  

The RISAFoundation software product (SOFTWARE PRODUCT) includes computer software, the 
associated media, any printed materials, and any electronic documentation. By installing, copying, 
accessing or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this 
agreement. If you do not agree with the terms of this agreement RISA Tech, Inc. is unwilling to license 
the SOFTWARE PRODUCT to you. In such event, you must delete any installations and destroy any copies 
of the SOFTWARE PRODUCT and return the SOFTWARE PRODUCT to RISA Tech, Inc. within 60 days of 
purchase for a full refund.  

Copyright © 2017 by RISA Tech, Inc. All rights reserved. RISA is part of the Nemetschek Group. The 
SOFTWARE PRODUCT is protected by United States copyright laws and various international treaties. All 
rights not specifically granted under this agreement are reserved by RISA Tech, Inc. “RISA” as applied to 
structural engineering software is a registered trademark of RISA Tech, Inc.  

1. SOFTWARE LICENSE. The SOFTWARE PRODUCT is licensed, not sold. All right, title and interest is and 
remains vested in RISA Tech, Inc. You may not rent, lease, or lend the SOFTWARE PRODUCT. You are 
specifically granted a license to the use of this program on no more than one CPU at any given time. The 
Network Version of the SOFTWARE PRODUCT is licensed for simultaneous use on a certain maximum 
number of network stations that varies on a per license basis. The Subscription Version of the 
SOFTWARE PRODUCT is licensed for simultaneous use on a certain maximum number of CPU’s that 
varies on a per license basis. As part of the license to use the SOFTWARE PRODUCT, the program user 
acknowledges the reading, understanding and acceptance of all terms of this agreement. The 
SOFTWARE PRODUCT may not be reviewed, compared or evaluated in any manner in any publication 
without expressed written consent of RISA Tech, Inc. You may not disassemble, decompile, reverse 
engineer or modify in any way the SOFTWARE PRODUCT. If the SOFTWARE PRODUCT was purchased at 
a discounted price for educational purposes it may in no event be used for professional design purposes. 
The terms of this license agreement are binding in perpetuity.  

2. DISCLAIMER. We intend that the information contained in the SOFTWARE PRODUCT be accurate and 
reliable, but it is entirely the responsibility of the program user to verify the accuracy and applicability of 
any results obtained from the SOFTWARE PRODUCT. The SOFTWARE PRODUCT is intended for use by 
professional engineers and architects who possess an understanding of structural mechanics. In no 
event will RISA Tech, Inc. or its officers be liable to anyone for any damages, including any lost profits, 
lost savings or lost data. In no event will RISA Tech, Inc. or its officers be liable for incidental, special, 
punitive or consequential damages or professional malpractice arising out of or in connection with the 
usage of the SOFTWARE PRODUCT, even if RISA Tech, Inc. or its officers have been advised of or should 
be aware of the possibility of such damages. RISA Tech, Inc.’s entire liability shall be limited to the 
purchase price or subscription price of the SOFTWARE PRODUCT.  

3. LIMITED WARRANTY. RISA Tech, Inc. warrants that the SOFTWARE PRODUCT will operate but does 
not warrant that the SOFTWARE PRODUCT will operate error free or without interruption. RISA Tech, 
Inc.’s sole obligation and your exclusive remedy under this warranty will be to receive software support 
from RISA Tech, Inc. via telephone, email or fax. RISA Tech, Inc. shall only be obligated to provide 
support for the most recent version of the SOFTWARE PRODUCT. If your version of the SOFTWARE 
PRODUCT is not the most recent version RISA Tech, Inc. shall have no obligation to provide support in 
any form. Except as stated above the SOFTWARE PRODUCT is provided without warranty, express or 

https://www.nemetschek.com/
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implied, including without limitation the implied warranties of merchantability and fitness for a 
particular purpose.  

4. PROTECTION DEVICE. In the event the SOFTWARE PRODUCT requires the use of a PROTECTION 
DEVICE to operate, you are specifically prohibited from attempting to bypass the functionality of the 
PROTECTION DEVICE by any means. A lost or stolen PROTECTION DEVICE will not be replaced by RISA 
Tech, Inc.  

5. SUBSCRIPTION SERVICE. In the event the SOFTWARE PRODUCT is accessed via a SUBSCRIPTION 
SERVICE, RISA Tech, Inc. shall make the SUBSCRIPTION SERVICE available for your use via an internet 
connection for the Term of the Subscription Agreement. At the end of the Term of the Subscription 
Agreement your right to access the SOFTWARE PRODUCT via the SUBSCRIPTION SERVICE will terminate 
unless the Subscription Agreement is renewed. RISA Tech, Inc. does not guarantee the SUBSCRIPTION 
SERVICE will be available error-free or uninterrupted. You acknowledge RISA Tech, Inc. does not control 
the transfer of information over the internet and that the SUBSCRIPTION SERVICE may be subject to 
interruptions or delays beyond the control of RISA Tech, Inc. RISA Tech, Inc. is not responsible for any 
delivery failures or any other damages resulting from any problems with the SUBSCRIPTION SERVICE.  

6. TERMINATION. RISA Tech, Inc. may terminate your right to use the SOFTWARE PRODUCT if you fail to 
comply with the terms and conditions of this agreement. In such event, you must delete any 
installations and destroy any copies of the SOFTWARE PRODUCT and promptly return the SOFTWARE 
PRODUCT to RISA Tech, Inc.  

7. CHOICE OF LAW. By entering into this Agreement in accordance with Paragraph 1, above, you have 
agreed to the exclusive jurisdiction of the State and Federal courts of Orange County, California, USA for 
resolution of any dispute you have relating to the SOFTWARE PRODUCT or related goods and services 
provided by RISA Tech, Inc. All disputes therefore shall be resolved in accordance with the laws of the 
State of California, USA and all parties to this Agreement expressly agree to exclusive jurisdiction of, and 
venue in, the courts in Orange County, California, USA. No choice of law rules of any jurisdiction apply. 

8. PRIVACY POLICY. All information you provide and have provided, or which we otherwise collect and 
have collected, through or in connection with the SOFTWARE PRODUCT, including personally identifiable 
information about you, is subject to, and will be treated in accordance with, the then-current Privacy 
Policy located at http://risa.com/privacy, which is incorporated herein by this reference. By accessing, 
downloading, installing, using and providing information to or through the SOFTWARE PRODUCT, you 
consent to all actions taken by us with respect to such information in compliance with the Privacy Policy.  

 

  

http://risa.com/privacy


 Before You Begin 

9 

 

Installation 

Installation Instructions 

To install RISAFoundation, please follow these instructions: 

 Contact the RISA licensing department (license@risa.com) for a program installation link. 

 Click on the link from the email that they will send you. 

 Follow the on-screen instructions. 

RISAFoundation Customization–Important Assumption! 

Please ensure that when performing these tutorials, RISAFoundation has not been customized in any 
way, and is in the default, installed state. If the installation of RISAFoundation has been customized, you 
may reset the program defaults as follows: on the Tools menu, click Reset All Program Defaults. 

 

mailto:license@risa.com
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First Look at RISAFoundation 

Starting RISAFoundation 

This section describes the RISAFoundation user interface, the toolbars, and shortcuts. We recommend 
that you review this section before you begin the tutorials. 

Start RISAFoundation as follows: 

 On the Start button, click All Programs, select RISA, then select RISAFoundation. 

Windows and Dialog Boxes 

 
 

  

Title bar Main menu RISA toolbar Minimize    Maximize    Close 

Status Bar  Starting a Model dialog box  Workspace 
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Title bar The title bar at the top of your RISAFoundation window can be very useful. Besides containing 
the name of the file that is currently open, it can also be used to move the window and 
minimize, maximize, and resize the window. 

 

To move the window, press and hold the title bar with your mouse, then drag to the desired 
location.  

Minimize, 
Maximize, 
Close 

The three buttons  on the right of the title bar control the RISAFoundation window as 
follows: 

 Click Minimize  to minimize the window to a button on the taskbar. 

 Click Maximize  to maximize the window to full screen. Once it is full screen, click 
Restore Down  to restore the window down to its original size. 

 Click Close  to close the window. 

Workspace The actual work that you do in RISAFoundation will be in the main area on the screen, the 
workspace. Currently the workspace is empty except for the Starting a New Model dialog box. 
As you create new model views and spreadsheets they will also appear in the workspace.  

Status bar The Status bar at the bottom of your screen will report information about your model as you 
work. 

 If the letter “S” is dimmed, a solution has not been performed. After a solution has been 
performed, the letter “S” will become blue in color with a red checkmark (as shown below). If 
the “S” is yellow, this means you have solution results but there have been modifications via 
the Member Redesign dialog box. 

 

To the right of the “S” are 3 status boxes: 

 The first status box displays general information relative to the task you are 
performing. 

 The second (middle) status box reports the units of the current spreadsheet cell. As 
you move from cell to cell, look to the middle status box for the appropriate units. 
This box is empty if you are not working in a spreadsheet. 

 The third status box (on the far right) reports the cursor coordinates as you work in 
the model view. This will be demonstrated throughout the tutorial. 

Dialog 
boxes 

Dialog boxes are windows that help you perform a specific function within RISAFoundation. For 
example, the Starting a Model dialog box is presented when you first open RISAFoundation, 
which helps you find the file you wish to open.  
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Menus and Toolbars 

Main Menu 

 

The Main menu and its submenus provide access to all features RISAFoundation has to offer, as 
summarized below: 

File Provides access to file operations such as opening, saving, and exporting files. 

Edit Provides editing tools that help you modify and manipulate the spreadsheets. 
You may use this menu to add or remove information from the spreadsheets 
or to sort and mathematically manipulate current spreadsheet data. 

Settings Provides access to the Model Settings dialog box which may be used to 
modify settings specific to the model. 

Units Allows you to set units or convert existing units. 

View Allows you to open a new model view or adjust the current model view. 

Insert Used to insert drawing grids, slabs, beams, footings, and loads into the model. 
All of these items may be drawn graphically or entered in the spreadsheets. 
This menu provides access to the graphical methods that RISAFoundation 
provides, while the Spreadsheets menu gives you access to the spreadsheets. 

Modify Allows access to the graphic editing features and may be used to modify 
existing model elements. 

Spreadsheets Opens the spreadsheets. 

Solve Solves the model. 

Results Allows access to all analysis result spreadsheets. This button is dimmed when 
no results are available, such as before you run a solution. 

Tools Provides tools to help you organize, identify, and correct problems as you 
model the structure. Application Settings are also located here. 

Window  Manages all of the windows that you have open in RISAFoundation, whether 
they are spreadsheets or model views. Special tiling options are also available 
that relate to specific modeling tasks. 

Help Provides access to the RISAFoundation online Help menu. For more 
information on Help, see Using the Online Help on page 3. 
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Toolbars 

The most commonly used features available on the Main menu are also available on the toolbars as 
toolbar buttons. The toolbars are designed to speed up your workflow by placing these tools close to 
your workspace and making them easily visible.  

Unlike some of the other toolbars, the RISA toolbar never changes.The other toolbars change, 
depending on whether you are in model (graphical) view or spreadsheet view. 

 

 

If you are not sure what a particular toolbar button does, simply position your mouse cursor over the 
button and a short definition will display. 

Note: You will discover many methods of accessing the tools available in RISAFoundation. The methods 
you choose—whether menus, toolbars, or keyboard shortcuts—will simply be a matter of personal 
preference. 

  

Window toolbar  
(in Model View) – contains viewing 
commands 

Data Entry toolbar - provides quick 
access to spreadsheets (then toolbars 
switch to spreadsheet view) 
-AND/OR-  
Results toolbar - After the model is 
solved, the results are displayed here 

RISA toolbar – provides access to file 
operations, printing, changing design 
parameters, etc. 

Drawing toolbar -  
Toggle on with (CTRL+G) 

Selection toolbar – 
provides tools to 
help make selections 

Main 
menu 

In Model View 

Window toolbar – any 
time a spreadsheet is 
open, notice the window 
toolbar changes 

Selection toolbar 
- is not visible in 
spreadsheet view 

In Spreadsheet 
View 
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RISA Toolbar  

 

The RISA toolbar is located directly below the Main menu. Unlike some of the other toolbars, the RISA 
toolbar never changes. These buttons perform general actions such as opening and closing files, 
changing design parameters, printing, and solving the model.  

Window Toolbar  

…in Model View 

 

The Window toolbar is located directly below the RISA toolbar. When working in a graphic model view, 
the buttons provide model viewing tools, such as rotate and zoom, and others. 

…in Spreadsheet View 

 

When you are working in a spreadsheet, this toolbar provides spreadsheet editing tools, such as Sort, 
Block Fill and Block Math. 

Drawing Toolbar  

 

The Drawing toolbar provides tools to assist with creating and modifying your model graphically. This 
toolbar may be turned on and off (CTRL+G) as needed. 

Selection Toolbar  

…only visible in Model View 

The Selection toolbar is the vertical toolbar along the left side of the screen.  
It provides tools to help you select and unselect parts of the model.  

You will need to make selections when you do things like graphically edit a  
part of the model or print only part of the results.  
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Spreadsheet Toolbars  

(Data Entry and Results Toolbars)  

These two toolbars provide access to the spreadsheets. You can turn them on 

and off on the RISA toolbar by clicking the Data Entry button  or the 

Results button . 

The Data Entry toolbar is a vertical toolbar on the right of your screen. It looks 
different than the other toolbars because its buttons consist of text instead of 
images.  

The Results toolbar is very similar. It appears after the model has been solved 
and provides quick access to the results spreadsheets. 

Both toolbars allow you to access the spreadsheets very quickly while building 
and solving your model. The buttons appear in the general order as you may 
need them.  
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Managing Windows, Model Views, and Spreadsheets 

Managing Windows 

As you work in RISAFoundation, you will be working within model views and spreadsheets, each in their 
own window that may be moved around the workspace and resized as you wish. A powerful feature of 
RISAFoundation is the ability to have multiple model views and spreadsheets open at one time. The 
Window menu provides many options to help manage the display of these windows. 

 

Managing Model Views 

You may open as many model view windows as you like. This is especially helpful when working zoomed 
in on large models. You might have one overall view and a few views zoomed in and rotated to where 
you are currently working. You may have different information plotted in each view. 

Remember that the toolbars displayed by RISAFoundation vary depending on which window is active 
(the window with a colored title bar is the active window).  

For example, if your active window is a 
spreadsheet, and you are looking for the 
zoom toolbar, you will not be able to 
locate it until you click your model, 
switching to model view. Then you will be 
able to access the zooming tools, and all 
the other tools related to modeling. 

  

Scroll bar - to view information 
outside of the window’s viewing 
area, click the scroll arrows or drag 
the scroll bar to move the display 
one way or the other. 

Scroll  
arrows 
& scroll 
bar 

Minimize,  
Maximize, and  
Close buttons 
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Working in Spreadsheets 

Spreadsheets are comprised of rows and columns of data cells. To add or edit data in a cell, click the cell, 
making it the active cell, then type. Only one cell can be active at a time, and it is denoted in green. You 
can change which cell is active using the LEFT ARROW, RIGHT ARROW, PAGE UP, PAGE DOWN, HOME 
keys, etc. 

You may also select blocks of cells to work on. To select a block of cells, click and hold the mouse button 
in the first cell in the block, drag to the last cell in the block, then release the mouse. To select an entire 
row or column, simply click the row or column label. To select multiple rows or columns, click and drag 
the mouse across multiple row or column buttons. 

 

 

 

 

 

 

 

 

 

 

Column label – Click the 
column label to select 
the entire column 

Scroll bar 

Row of cells – Click the 
row label (at left) to 
select the entire row 

Column of cells 

Click any cell. Notice the 
status bar displays an 
explanation of the 
current column. 
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Part A: Building a Model from Scratch 

This first part of this book (Part A) will focus on building RISAFoundation models from scratch. With the 
guidance of the following four tutorials, you will build, solve, and modify a typical industrial foundation 
system comprised of several different types of foundations.  

The tutorials build upon themselves from start to finish. You have the option of performing them all at 
one time, or performing each one separately. To make this possible, RISA provides model files for you to 
load at the beginning of each tutorial. These starter files are located in My Documents in the 
RISA\Model Files folder under Tutorials, and are named Tutorial A2 starter.fnd, Tutorial A3 starter.fnd, 
etc. 

When you finish all four tutorials, the final product will look like this: 

 

 

To complete all four tutorials will take only a few hours. However, you can speed up the process even 
further if you skip the supporting text and concentrate only on the action steps, which are indicated 
with diamond-shaped bullets, as shown below: 

 In order for you to achieve accurate results, it is important that you do not miss any of these 
action steps while performing the tutorials. 
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Part A: Tutorial 1 – Modeling 

Overview 

This first tutorial will introduce the various drawing features that RISAFoundation has to offer. You will 
model a project grid, a slab, several footings and grade beams, and explore the Model Settings.   

Starting a New File 

When you are ready to begin, start RISAFoundation if you have not already done so: 

 Double-click the RISAFoundation icon to start the program. The Starting a Model dialog box will 
display, which allows you to create a new model or open an existing file.  

 

You have several startup options: you can choose to start drawing your model (either by defining beams 
or slabs, or using a template to generate it automatically), you can open an existing model, or you can 
click Close to work on your own.  

You will now begin your model by drawing the slabs: 

 Under Create a New Model, select the Open the Model Settings window also check box. This 
will save you a step by opening the Model Settings dialog box after you make your starting 
selection. 

 Select  to immediately start drawing slabs. 

Because you selected the Open Model Settings check box option, the Model Settings dialog box opens 
first. This dialog box provides access to model settings that apply to the model as a whole.  

Note: The appearance of your 
menus and toolbars may look 
slightly different, depending 
on your computer screen 
resolution and font sizes. 
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Set Model Settings 

Set the Model Settings as follows: 

 Type a model title, company name, and your name, as shown below.  

 Click Apply. The dialog box will remain open. 

The Model Settings dialog box: 

 

Review the Solution settings. 

 In the Model Settings dialog box, click the Solution tab. Review the Solution settings, as 
summarized below. 

Number of Sections Defines the number of beam force, stress, and deflection results will be reported for 
each member. 

INTERNAL Sections Defines the number of places along each beam the software calculates and stores 
results (such as deflections and code checks). The beam force diagrams displayed in 
the model view and the detail plot are also drawn from these results. 

Mesh Size Defines the coarseness or fineness of the slab mesh when RISA auto-meshes slabs 
during solution. 

Max Iterations Defines the maximum number of iterations RISA will perform during a solution. 

Coefficient of 
Friction 

Defines the value used to calculate the resistance against sliding in the slab sliding 
check. 

Merge Tolerance Defines the maximum distance two points can be apart and still be merged together. 
It is also used when scanning for crossing members and for unattached joints along 
the spans of beams. 

Tip: 
Press TAB to 
advance to the next 
field. 

Type any notes you 
would like to keep 
with the model in 
the Notes area. 
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Solver Defines which solver will be used.  

Save As Defaults Saves all the modified information in this tab as the default settings for all future 
models.  

 

Modify the Solution parameters: 

 Under Beam Section Options, in the Number of Sections box, type 7 (or you may use the 
up/down arrows to increase/decrease the value). In the INTERNAL Sections box, select 100. 

 In the Mesh Size box, type 36. 

 Click Apply (the settings will be applied and the dialog box will remain open). 
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Review the Design settings. 

 Click the Design tab. Review the Design settings, as summarized below: 

# Shear Regions Allows you to control the number of regions to be used when detailing  
a beam span. 

Region Spacing Incr. Used to increase or decrease the spacing of shear ties during design 
optimization. 

Optimize Footings for 
OTM / Sliding 

Defines whether or not you want the program to optimize footings 
based on overturning and sliding. 

Min 1 Bar Dia Spacing 
(for Beams Only) 

Defines a minimum spacing of one bar diameter between parallel bars. 
Otherwise, RISA will default to a two-bar diameter or one-inch clear 
spacing (whichever is greater) to allow for lap splices and continue to 
maintain adequate spacing between parallel bars. 

Concrete Stress Options Defines the type of stress block to consider in your analysis. 

Concrete Rebar Set Defines which reinforcement standard set will be used in your design. 

Parme Beta Factor This value is used to approximate the column’s 3D interaction surface 
when using the PCA Load Contour Method. 

Code Defines the concrete/masonry/pile design code for your solution.   

Pile Safety Factor Allows you assign a safety factor for the design of piles. 

 

Modify the Design settings. Because the Parabolic Stress Block is more accurate, select this option: 

 Under Concrete Stress Options, click Parabolic Stress Block. 

 Uncheck the Optimize Footings for OTM/Sliding checkbox. 

 

 Click OK to save your settings and close the Model Settings dialog box. 
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Drawing Slabs 

Now that you have defined the Model Settings, the Draw Slabs dialog box will display, as shown below: 

 

For now, use one of the default materials and define a 30 inch, 4 ksi NW slab.  

 In the Material Set list, click Conc4000NW.  

 In the Thickness box, type 30. 

 Click Apply to begin drawing.  

Note: Your cursor changes to , indicating that you are now in drawing mode. To exit this mode at any 
time, right-click your mouse or press ESC. 

Drawing Grid vs. Project Grid 

Every time you start a new model, RISAFoundation automatically opens a 30x30 drawing grid. Although 
you can use this grid for your model, it is preferable to define a Project Grid. The benefit of using a 
Project Grid is that this grid will actually be linked to your model. For example, if you have a row of 
footings on a gridline, and decide to move that gridline, the footings move right along with it. 

First, toggle off the display of the Drawing Grid: 

 On the Drawing toolbar, click Drawing Grid  to turn off the display of the grid. 

Now, draw the Project Grid: 

 On the Data Entry toolbar, click Project Grid. (If the Data Entry toolbar is not visible on the right 
side of your screen, you may need to turn it on. On the RISA toolbar, click the Data Entry toolbar 

button  to turn it on or off.) 

 Click Generate Project Grid Lines. 

The foundation you will be modeling is shown below. You will use the dimensions from this drawing to 
create your Project Grid.  

The Material Set list contains six material 
types available as a default in 
RISAFoundation. If you would like to use a 
different material, add it as a new entry in 
the Materials spreadsheet (by adding a new 
line or row). 
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To define the gridlines for each axis, you will type all the values at once under the Rectangular Grid 
Parameters section: 

 In the Z Axis Increments box, type 3,2@25,3,22,2@25,3,12 (separated by commas). 

 In the X Axis Increments box, type 3,20,17,3,3@20,3 (separated by commas). 

Your Rectangular Grid Parameters section should look like this: 
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For Z Direction/Radial Line Labeling: 

 In the Start Label box, type 1. 
For the Label Order, click A to Z. 

For X Direction/Radial Line Labeling: 

 In the Start Label box, type I (capital “i”). 
For the Label Order, click Z to A. 

 

Your Project Grid Lines dialog box should look like this: 

 

 Click Ok. 
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The spreadsheet should look similar to below: 

 

Close the spreadsheet: 

 Click Close  to close the spreadsheet. 

 On the Window toolbar, click Redraw  to redraw the grid in the current window. 

Your Project Grid will now be displayed in light blue, as shown below: 

 

Notice that you are no longer in drawing mode, and the cursor has returned to  (this occurs any time 
you open a spreadsheet).  

  

Tips for Typing Data in Spreadsheets: The 
green highlighted cell is the active cell. 
You can change the active cell by clicking 
in a new cell, or use the TAB key or arrow 
keys to move around in the spreadsheet. 

You may use the keyboard or the numeric 
keypad for typing numbers. 

To view all 19 rows, you may 
need to lengthen your 
spreadsheet. Click and drag 
the right corner of the 
spreadsheet in a downward 
motion. 

Note: The Project Grid 
displays in light blue while 
a Drawing Grid would be 
displayed in grey. 
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Resume the drawing mode: 

 Select  to recall the Draw Slabs dialog box (no setting changes are necessary, as the settings 
you made a few steps earlier for Material Set and Thickness are still present on the dialog box). 

 Click Apply to begin drawing the slab. 

Use the grid intersections you just created (above) as pick points to draw the slab. 

 Click the following grid intersections (in this order): A1, A9, F9, F5, I5, I1, then click A1 a second 
time to close the polygon. 

Note: Once you close the polygon, by clicking the first grid intersection a second time (in this case A1), 
the slab will appear. 

If you make any mistakes as you draw, use the Undo  or Redo  buttons to undo or redo your last 
step (they are located on the RISA toolbar). 

Your model should now look like this: 

 

Pedestals 

The Pedestal feature in RISAFoundation allows you to draw rectangular or circular pedestals anywhere 
on a slab. For your foundation, you will use both types of pedestals. You will start with circular 
pedestals, and then later modify a few of those to rectangular (in Tutorial 2). 

 On the Insert menu, select Pedestals/Posts to open the Draw Pedestals/Posts on Slab dialog 
box. 

 In the Draw Pedestals tab,  under the Concrete Pedestal/Post box, click Concrete Pedestal.  

 Under the Shape/Size box, click Circular. In the D (Diameter) box, type 24.  

 In the Material Set list, click Conc4000NW. In the Height box, type 12. 

The slab edge  is 
displayed as  a 
thick blue line 



Part A: Tutorial 1 – Modeling 

28 

 

 

 Click Apply. 

Rather than click each grid intersection one at a time to place each pedestal, you can use the box select 
function of the drawing tool to select a group of grid intersections. Use the “box” method to select all 
the grid intersections between B2 and E4 (shown below): 

 Box the grid intersections between B2 and E4. To do this, click your mouse slightly above and to 
the left of grid intersection B2, hold and drag the mouse slightly beyond grid intersection E4, 
then release.  

Box the grid intersections, as shown.  

 

Once you release the mouse, you will see 12 pedestals drawn onto your slab.  

Note: It may be helpful to zoom in a bit on your 

model. On the Window toolbar, click Zoom In  
or use the zooming shortcut by rolling your 
mouse wheel in an upward motion. 
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Make two more box selections to complete the pedestal layout: 

 Box the grid intersections between G2 and H4. 

 Box the grid intersections between B6 and E8. 

 When finished, your model should look like this: 
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Footings 

Next, you will draw the six footings. Start by defining a footing layout and then apply that layout to the 
project grid. 

 On the Spreadsheets menu, click Footing Definitions. 

This opens a spreadsheet that contains all the design parameters for footing design. To create additional 
footing designs, simply add as many additional rows to this spreadsheet as you like.  

 

Browse through the various tabs in the spreadsheet to explore the contents. You will use the default 
entries so, when finished reviewing, close the spreadsheet. 

 Browse through the various tabs in this spreadsheet. 

 Click Close  to close the spreadsheet. 

Note: If you need help while in a spreadsheet, simply hit the F1 key. The Help will open to a description 
of that spreadsheet. 

Now that you have defined your footing, you may apply it to your model. 

 On the Insert menu, click All Support Types. This dialog box allows you to apply typical supports 
(Reaction, Spring, etc.), footings, and pile caps.  

 In the Assign Footing list, select Footing 1 (this is the one you just reviewed in the Footings 
spreadsheet). (Notice that you can also apply a rotation angle to your footing. But in this case, 
you will use the default of 0 degrees.) 

 

 Click Apply.  

Note: After you click Apply, your mouse changes to  indicating that you are now in drawing mode. 
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In the next few steps, you will be defining six footings for your model. Only two of the six footings fall on 
grid intersections (B10 and C10). Begin by drawing those two footings: 

 Click grid intersections B10 and C10. 

Because four of the footings are not on grid intersections, you must use coordinates and snap options to 
define their exact location. 

 On the Drawing toolbar, click Modify Drawing Grid . Click the Snap to Options tab. 

 Under Universal Snap Increments, make sure that the Z Axis Increments and X Axis Increments 
are both set to 1 ft. Select the Use Universal Increments check box. 

 Click Ok. 

As you move your cursor around your model, notice a red star will appear at every 1 ft increment, as 
specified above. To see it more clearly, you may need to zoom in on the model by rolling the mouse 
wheel forward (away from you). 

Also, as you move your mouse, notice the coordinates of the grid intersections are displayed in the 
lower right corner of the status bar, as shown below. 

  

 

 

Note: The cursor provides additional information regarding the cursor coordinates. As you move your 
cursor around on your screen, a box adjacent to your cursor will appear and populate with the 
coordinates of the cursor. 

  

Assign the final four footings by defining their coordinate locations, as shown below. 

 Click the following coordinate locations: 
(88, 13)   (108, 13)   (88, -7)   (108, -7) 

 Right-click the mouse or press ESC to exit the drawing mode. 

  

Status bar Coordinates of the current 
grid intersection location of 
the mouse cursor. 
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When finished, your model should look like this: 

 

 

Grade Beams 

Note: RISAFoundation treats beams as physical members. This means that the beams will provide fixity 
to all joints that occur along the span of the member. Therefore, to be able to later connect the beams 
to intermediate elements, it is not necessary to break them into individual members.  

To give additional stability to the footings at grid intersections B10 and C10, you will draw some grade 
beams. First, turn off the snap points and zoom in on your model so you can view those grid 
intersections closer: 

 On the Drawing toolbar, click Universal Snap Points  to turn off the snap points. 

 On the Window toolbar, click Zoom In  (or roll the mouse wheel forward). Use the scroll bars 
to reposition the model so that grid points B8 and B10 are in clear view. 

Next, you will define the material to be used for the beams: 

 On the Insert menu, click Beams. 

 In the Material Set list, select Conc4000NW. In the Depth(D) box, type 24. In the Width(W) box, 
type 18. 
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 Click Apply. 

Now, draw the first beam: 

 Click grid intersections B8 then B10. Notice that your cursor remains linked to the node at B10, 
allowing you to continue drawing a second beam without interruption (which you will do in the 
next step). 

 

Continue drawing the remaining beams: 

 Click grid intersection C10 to create the second beam; and finally C8 to create the third beam.  

 Now that you are finished drawing your beams, right-click the mouse or press ESC two times to 
terminate drawing and exit the drawing mode. 

After drawing a beam, your cursor 
remains linked until you either 
draw another beam or terminate 
drawing. 

To terminate drawing beams, right-
click the mouse or press ESC.  

To exit the drawing mode 
completely, right-click the mouse 
or press ESC a second time. 
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Now that you have completed drawing your foundation elements, render the view: 

 On the Window toolbar, click Redraw  to resize the model within the window. 

 On the Window toolbar, click Rendering  to view your model with a color fill. 

 

Soil Regions 

Soil regions may be applied to your model in individual areas if you want them to vary from the default 
soil properties by accessing the Soil Definitions Editor. For your model, you will use this editor to apply 
different soil regions under different parts of your model. Start by setting a default Subgrade Modulus. 

 On the Data Entry toolbar, click Soil Definitions to open the Soil Definitions spreadsheet box. 

 In the Label column click the first cell to highlight the label.  Click a second time on the red 
arrow. 

 In the Label box, type Soil 1. 

 In the Subgrade Modulus box, type 120. 

 In the Allowable Bearing box, type 5. 

 

Apply the changes and close the dialog box: 

 Click OK. 
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Now, this will be the default subgrade modulus for the model and it will be used to establish the elastic 
stiffness of the soil for the entire model. Because you want to establish an area with a different 
Subgrade Modulus and Allowable Bearing Pressure, you will do so with the Soil Definition Editor tool. 

 Type Enter in the Soil Definitions spreadsheet, click the first cell in the second row (labeled ‘Soil 
2’), click a second time on the red arrow. 

 In the Subgrade Modulus box, type 100. 

 In the Allowable Bearing Pressure box, type 4.   

 

 

Now that you have defined your soils, you will draw in a soil region where the soil differs from the 
default. 

 On the Drawing toolbar, click Draw or Modify Soil Regions . 

 Select Soil 2 as your Soil Definition. 

 

 Click Apply to begin drawing the region. 
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To draw the soil region over the four footings you created earlier (at the bottom of the model), you will 
need to turn Universal Snaps back on and draw your soil region as follows: 

 On the Drawing toolbar, click Universal Snap Points  to turn on the snap points. 

 Click grid intersections G6, G8, then coordinates (128, -16), (78, -16), and finally click grid 
intersection G6 a second time to close the polygon. 

Note: If you had drawn your soil region under just a portion of a footing, the footing would be designed 
for the soil type under the defining footing joint. They will not be designed for half one soil region, half 
another. 

This completes your initial foundation design. You may now change to rendered, isometric view and 
review your model for accuracy: 

 On the Window toolbar, click Isometric to view the model in isometric view. 

 On the Window toolbar, click Rendering  once more to view the full rendered view. 

 

 

 

This is the end of Tutorial A1. 

You can save your model to be used as the starting point for the next tutorial, or begin the next tutorial 
using the .fnd starter file in the RISAFoundation Tutorials folder. To save the model: 

 Select Save As from the File menu. Enter in a file name and click Save. 
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Part A: Tutorial 2 – Modifying 

Overview 

Now that you have laid out your RISAFoundation model, it is inevitable that modifications or changes 
will need to be made. One of the most powerful features of RISA software is the ability to quickly and 
effectively make changes to an existing model without having to recreate the model—this tutorial will 
demonstrate how. 

Getting Started 

This tutorial continues where the previous tutorial ended, if you are continuing from the previous 
tutorial: 

 On the Main menu, select Single View from the Window menu. 

 On the Window toolbar, click the Graphic Editing Toolbar button  to activate the Drawing 
toolbar. 

 Skip ahead to the next section titled Model Manipulation. 

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA : 

 Double-click the RISAFoundation icon to start the program. 

 Click Open File  from the Starting a Model dialog box.  
Double-click the Model Files folder then the Tutorials folder, select Tutorial A2 Starter.fnd and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the Window toolbar, click the Graphic Editing Toolbar button  to activate the Drawing 
toolbar. 

Your model should now look like this: 
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The first part of this tutorial will guide you through some of the basic graphical functions of 
RISAFoundation. As you build larger, more complex models, the view manipulation features (such as 
zooming, panning, and rotating) will help you ensure model building precision during every step of the 
process. 

The Window toolbar provides these view manipulation features: 

 

Model Manipulation 

Rotating 

The Rotate buttons  are used to rotate the model with respect to the global axes of 
the model. Display the model as rendered while you explore these options. 

 Click the Toggle Rendering button  twice. 

The model will now display in rendered view. 

 

Experiment using some of these view manipulation buttons: 

 Click each of the Rotate buttons  a few times. Watch the global axes icon to 
see the effect of each. 

 Click Isometric  to snap the model into isometric view.  

 Now that you are in isometric view, click the Rotate buttons  once again to 
see how the model rotates in 3D. 

 When you are finished, click the Isometric button  once more to bring your model back into 
isometric view.  
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Your model should now look like this in isometric view: 

 

 Return to wireframe view by clicking the Toggle Rendering button  once. 

 

Zooming 

The Zoom buttons  are also located on the Window toolbar, just to the right of the Rotate 
buttons. These are used to zoom in or zoom out of your model.  

 Try clicking on these buttons to experiment with them.  

The last zoom button, the Box Zoom button allows you to use your cursor to draw a box around 
the area you would like to zoom in on. Try this by adjusting your model view, then zoom in on the four 
footings in the lower portion of the model: 

 On the Window toolbar, click Redraw  to redraw the model in full model view. Then, click 

Plan  to snap back to a XZ planar view. 

 On the RISA toolbar, click the Data Entry toolbar button  to close the Data Entry toolbar (or 

click Close  on the Data Entry toolbar itself). 

 On the Window toolbar, click Box Zoom  and then draw a box around the lower four 
footings by clicking and dragging your mouse. When you release the mouse, the boxed area will 
zoom in to the full size of the window.  
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If your mouse has a wheel, you will also be able to zoom using the mouse wheel: 

 Roll the mouse wheel forward and backward a few times to see the zooming effect.  

 On the Window toolbar, click Redraw  to redraw the model within your window. 

Panning 

With the mouse wheel, you will also be able to use RISAFoundation’s panning feature: 

 Simply press down the mouse wheel anywhere on your model, then hold and drag to the 
desired location. This will drag your model to the new location. 

When you are finished, return to your original, full model view:  

 On the Window toolbar, click Plan , then Redraw . 

Your window should now look like this: 

  

You may also zoom in and out 
using the wheel button on 
your mouse. Roll the wheel 
forward to zoom in, and back 
(towards you) to zoom out. 
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Multiple Views  

RISAFoundation provides the ability to display multiple views of your model using two powerful tools: 

Clone View  and New Model View . These tools allow you to keep your original model view 
(window) intact in one view, then create additional views to display different views of the model.  

 

Listed below are some scenarios in which you may want to use these tools: 

 To isolate specific parts of your model to see how those parts are affected by your 
modifications.  

 If you do not want to change your existing view, but need to view a different side of the model, 
simply open a new window to view the other side.  

 When viewing results, you can plot different results information in each view.  

 Clone View  is currently not shown on the toolbar.  To access this button go to Tools - 

Customize Toolbar.  Here you will find Clone View  as well as several other quick acess tools 
you can add to your toolbar by clicking on the applicable tool and Add. 

 

New Model View - opens a new window 
containing the current model view (but does 
not include any rendering or view 
modifications). 

Example 1. Notice the current model 
view is in isometric view and rendered-
-the cloned view is identical. 

Example 2. Even though the original model 
view is rendered and in isometric view, the 
New Model View opens in wireframe, XZ Plan 
view (the RISAFoundation default view). 

Clone View - opens a new window 
containing the current model view 
(including any rendering or viewing 
changes you have made). 
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Note: Each view, whether created with Clone View or New Model View, is independent and can be 
rotated, rendered, zoomed, selected, etc., without affecting the other model views. However, any 
modeling changes you make in any view will be automatically updated in the other views. 

You will now explore this feature a bit. Before you create a new model view, turn the joint labels off, so 
you will be able to visually see the difference between this view and the newly created view: 

 On the Window toolbar, click Joint Labels  to turn off the joint labels. 

Now, create a new model view: 

 On the RISA toolbar, click New Model View . 

Compare the two model views you now have open. On the newly created model view, notice the node 
labels are turned on (even though you turned the node labels off on the original window; remember 

viewing changes are not reflected when using the New Model View  tool). 

 

Render your new model view, then compare again: 

 Place your cursor in the newly created model view to make sure it is the active window. 

 On the Window toolbar, click Rendering  two times to render the new model view. Notice 
the original view remains unchanged. 

The new model view 
is now the active 
view.  To move back 
and forth between 
the views, click in the 
windows. Or, on the 
Window menu, 
select the view you 
want to make active. 
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Next, you will modify the model a bit so you can see the effect on each view: 

 Make sure your newly created model view is the active window. 

 Press CTRL+G to open the Drawing toolbar. 

 On the Drawing toolbar, click Delete . 

The Delete Items dialog box will display: 

 

Specify the four footings you want to delete, then compare the views: 

 Click Delete LOADS/ITEMS by Clicking Individually, then click Apply. 

 Click to delete the four footings at the base of the model.  

 Click back to the original model view.  
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Notice that the four footings have also been deleted from the other model view. 

 

Since you actually want to keep these footings in your model, undo the last four deletions: 

 On the RISA toolbar, click Undo  four times to return the footings back to the model. 

 On the Window menu, select Single View to return to the original, full size model view. 

Your model should now look like this: 
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Modifying the Model 

Selection Tools 

In this section, you will explore how to combine the viewing options you just learned about with the 
selection tools to make those inevitable model design changes in RISAFoundation. 

Next, you will modify your model to look like this: 

 

The entire model is currently selected, so start by unselecting the entire model, then select only the 
parts you want modified (in this case, the pedestals in the front, lower region of your slab): 

 On the Selection toolbar, click Unselect All  (the Selection toolbar is located on the left side 
of your screen). 

Note: When you unselect elements, they will display in grey. Any modifications you make to the model 
will only apply to “selected” elements. Therefore, selecting and/or unselecting elements enables you to 
isolate various portions of your model. For example, any elements that are selected will be modified; 
any elements that are unselected will be excluded. 
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Next, you will use the Criteria Selection  tool to select the pedestals (and exclude all the other 
elements). 

 On the Selection toolbar, click Criteria Selection . Click the Pedestals/Posts/Walls tab. 

 Under Pedestals/Posts Properties, in the Shape list, click CRND24.  

 Select the Use? checkbox in the upper right corner. 

 Under Selection Options, click Select Items?  

Next, define the X and Z coordinates: 

 Click the Coordinates tab. 

 Under Coordinate Bounds, enter these values: 
In the X Coordinate row, in the Maximum column, type 23 (leave the Minimum column blank).  
In the Z Coordinate row, in the Minimum column, type 3. In the Maximum column, type 53. 

Pay close attention to the selection options near the bottom of the dialog box: 

 Under Selection Options, click Select Items?  

 Select the Include Criteria On Other Pages? check box (if it is not already selected).  

 

 Click OK. 
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Only the lower six pedestals will be selected, as shown below. 

 

Now that you have selected the pedestals to be modified, use the modify tool to quickly update your 
model. 

 On the Modify menu, select Pedestals/Posts. 

 In the Pedestal Shape and Dimensions area, select the Use? check box. Then, click Rectangular. 
In the D (depth) box, type 30. In the W (width) box, type 24.  

 Under What happens when Apply is pressed? select Apply Entries to All Selected 
Pedestals/Posts. 

The dialog box should look like this: 

 

Once you verify the entries are correct: 

 Click Apply. 
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Notice that all selected pedestals have become rectangular. Select the remaining pedestals so you can 
compare the two pedestal types: 

 On the Selection toolbar, click Criteria Selection . Click the Pedestals/Posts/Walls tab. 

 Under Pedestals/Posts Properties, in the Shape list, select CRND24.  

 Select the Use? checkbox in the upper right corner. 

 Click OK. 

Now, all your slab pedestals are selected as shown below: 

 

Before you re-select the entire model, save this selected state so that you may access it for later 
modeling and/or modifications: 

 On the View menu, select Save or Recall Selection States. 

 Click Save. A dialog box will appear asking for a description name.  

 Type: Slab Pedestals. 

 

 Click Ok. Then click Close. 

Now you have saved this selection state and may retrieve it any time by coming back to this tool (on the 
View menu, select Save or Recall Selection States, then clicking the Retrieve button). 
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Return to your model view and select the entire model. 

 Place your cursor anywhere in the model view, and right-click your mouse. A shortcut menu will 
appear, click Select, then click All. 

The shortcut menu appears: 

 

Now the entire model will be selected again, as shown in the image below: 
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Design Rules 

The Design Rules spreadsheet allows you to define or change the parameters for your solution, as you 
will do next: 

 Verify that the Data Entry toolbar is visible on the right side of your workspace. If not, on the 

RISA toolbar, click the Data Entry toolbar button .This toolbar provides quick access to the 
spreadsheets. 

 On the Data Entry toolbar, click Design Rules to open the Design Rules spreadsheet. 

 

Review the General and Beam parameters: 

 Click the General and Beam tabs to scan through the available options. There is no need to 
change any of the default parameters for these two tabs. 

Modify the Slab parameters: 

 Click the Mat Slab tab. Modify the parameters so that your spreadsheet matches the image 
below. 

 

Modify the Footing parameters: 

 Click the Footing/Pile Cap tab. Modify the parameters so that your spreadsheet matches the 
image below. 

 

Modify the Pedestal parameters: 

 Click the Pedestal/Pile tab. Modify the parameters so that your spreadsheet matches the image 
below. 

 

When finished, close the spreadsheet: 

 Click Close .  
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Circular Slabs 

Now that all the existing elements have been modified, add the circular slab in the lower right hand 
corner using the Circular Slab Generator. 

Note: This generator can be a very useful tool. Besides generating the slab, it will also add loads to the 
slab, and add the design strips within the slab. Loads and design strips will be explained in more detail in 
later tutorials. 

 On the Insert menu, select Circular Foundation. This will open the Circular Slab Generator 
dialog box.  

 Complete the dialog box so that it matches the image below. 

 

 Click OK. 
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Notice the slab is now drawn on your model. 

 

Notice that the circular slab overlaps the soil region you drew earlier. So, next, you will modify the soil 
region to extend completely under the new slab. The best way to do this is to simply change the 
coordinates of the four nodes that define the corners of the soil region. 

First, zoom in for better viewing of this region: 

 Zoom in on the lower right corner of your model using zooming and panning techniques. 

 

  

Zooming shortcut: Zoom in by 
rolling the mouse wheel 
forward. 

Panning: To move the model 
around in the window, press 
the mouse wheel down, hold 
and drag in any direction. 
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Get information on the node that defines the upper right corner of the soil region: 

 Double click the upper right corner node N44 (at coordinates 128,23) of the soil region.  

This opens the Information dialog box for that point. 

 

Change the coordinates to extend beneath the new slab: 

 Under Coordinates, in the Z Coordinate box, type 165. In the X Coordinate box, type 40.  

 Click OK. 

Now, extend the node that defines the lower right corner of the soil region: 

 Double click the node N45 (at coordinates 128,-16). 

 Under Coordinates, in the Z Coordinate box, type 165. In the X Coordinate box, type -35.  

 Click OK. 

 Click Redraw  to view the entire model again. 
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Your soil region has now expanded beyond and lies beneath the new circular slab. You can also view 
your model in isometric, rendered view. 

 Click Iso  to place the model into isometric view. 

 Click Rendering  twice to place the model into a full rendered view. 

 

 

 

 

 

 

 

 

This is the end of Tutorial A2. 

You can save your model to be used as the starting point for the next tutorial, or begin the next tutorial 
using the .fnd starter file in the RISAFoundation Tutorials folder. To save the model: 

 Select Save As from the File menu. Enter in a file name and click Save. 
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Part A: Tutorial 3 – Loading 

Overview 

With the model layout complete, you can now explore the many ways to apply loading in 
RISAFoundation. In the previous tutorial, you applied both a line load and an area load to your circular 
slab with the circular slab load generator. In this tutorial, you will be expanding on this by adding some 
additional line loads and point loads.  

Getting Started 

This tutorial continues where the previous tutorial ended, so follow these steps to get your model up 
and running: 

If you are continuing from the previous tutorial: 

 On the Main menu, select Single View from the Window menu. 

 On the Window toolbar, click the Graphic Editing Toolbar button  to activate the Drawing 
toolbar. 

 Skip ahead to the next section titled Adding Loads. 

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA : 

 Double-click the RISAFoundation icon to start the program. 

 Click Open File  from the Starting a Model dialog box.  
Double-click the Model Files folder then the Tutorials folder, select Tutorial A3 Starter.fnd and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the Window toolbar, click the Graphic Editing Toolbar button  to activate the Drawing 
toolbar. 

Your model should look like this: 
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Adding Loads 

You will find that whenever you define a load in RISAFoundation, you will also immediately assign it to a 
load category. The load categories are then used to combine the loads into load combinations (along 
with multiplier factors) for solution. 

Line Loads 

Line loads in RISAFoundation are all applied with positive magnitude signifying a downward force. You 
can use line loads to model the equipment bearing on the foundation. 

 On the Drawing toolbar, click Draw Line Loads . 

 In the Load Category Code list, click LL-Live Load. Then, in the Start Magnitude box (and the End 
Magnitude box), type 20. 

 

 Click Apply. 

To ensure accurate grid selections, turn on the snap points and zoom in on your model view: 

 On the Drawing toolbar, click Universal Snap Points . When selected, the button will appear 

pressed in .  

 On the Window toolbar, click Zoom In  a few times (or roll the mouse wheel forward). This 
will enlarge your model making it easier to view.  

Note: Once you zoom in, you may need to move your model around on the screen to reposition the 
model. Use the panning technique described earlier (press the mouse wheel down, hold, then drag the 
model view in any direction). 
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Now, make your grid selections by defining their coordinate locations, as shown below. 

 Click the coordinate location (3, 75), then (53,75). Right click (or press ESC) to release the 
mouse. 

 Click the coordinate location (3, 71), then (53,71). Right click (or press ESC) two times to release 
the mouse and exit the drawing mode. 

Now that you have made your grid selections, zoom back out to full model view. 

 On the Window toolbar, click Redraw . 

When you are finished, your model should like this: 

 

 

Point Loads 

Point load direction is the same as for line loads; a positive force signifies a downward force. You can use 
these to model loads to the pedestals, or apply them anywhere on the slab. 

Start by applying load to the slab pedestals. You can do this easily by unselecting the entire model, then 
retrieving your Slab Pedestals selection state from the previous tutorial: 

 On the Selection toolbar, click Unselect All .  

 Also on the Selection toolbar, click Save/Recall Selection . Make sure that Slab Pedestals is 
selected, and click Retrieve.  
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Now that your pedestals are selected, you are ready to apply load. 

 On the Drawing toolbar, click Draw Point Loads . 

 In the Load Category Code list, click DL-Dead Load. In the Magnitude box, type 20. 

 Under What happens when Apply is pressed?, click Apply Load to All Selected Points. 

 

Verify the dialog box settings, then apply: 

 Click Apply. 

Notice the loads have been added, and your model should now look like this: 
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Next, apply the live loads:  

 On the Drawing toolbar, click Draw Point Loads  (or press CTRL+D to recall the last dialog 
box). 

 In the Load Category Code list, select LL-Live Load. In the Magnitude box, type 15. 

 Under What happens when Apply is pressed?, click Apply Load to All Selected Points. 

 

Verify the dialog box settings, then apply: 

 Click Apply. 

 

Lastly, apply loading to your footings. 

Note: As soon as you apply this load, notice 
the Window toolbar loads display button 
switches to display only the LL-Live Load 

category loads  (this will be 
explained in more detail later in this 
tutorial). 
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 On the Selection toolbar, click Unselect All  to unselect the entire model. 

 Also on the Selection toolbar, click Criteria Selection . Click the Supports/Beams tab. 

 In the Point Selection Criteria area, select the Use? check box. Under Point Properties, in the 
Footing list, click Footing 1. 

 

Verify the dialog box settings, then apply: 

 Click OK. 
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Continue adding loads, but this time use the Insert menu to access the Point Loads dialog box: 

 On the Insert menu, click Loads, then click Point Load. 

 In the Load Category Code list, click DL-Dead Load. In the Magnitude box, type 15 and in the 
Dir. Box, type Y. 

 Under What happens when Apply is pressed?, click Apply Load to All Selected Points. Also, 
select the Keep this dialog open check box. 

 Click Apply. 

Verify that the load was properly applied on your footings. (If you need to move the Draw Point Loads 
dialog box, click the title bar and hold, then drag the dialog box to the new location.) 

Finish adding your loads:  

 In the Load Category Code list, click LL-Live Load. In the Magnitude box, type 10 and in the Dir. 
Box, type Y. 

  Click Apply. 

 Then, click Close to close the dialog box. 

Now that you have finished applying your loads, you can verify their accuracy by viewing them in the 
spreadsheets. 

 On the Spreadsheets menu, click Load Categories. 

 

This spreadsheet displays the total number of each type of load you have applied to each load category. 
This may be used as a quick check to make sure your loads are assigned to the appropriate categories. 

Close the spreadsheet and return to the model view: 

 Click Close . 

Load Combinations 

Now that you have applied all your loads, you can combine them with multiplying factors to create load 
combinations. RISAFoundation offers two ways to do this: you can either enter your load combinations 
manually into the spreadsheets, or use the Load Combination Generator to generate your load 
combinations automatically. 

For this tutorial, you will generate your load combinations automatically using the Load Combination 
Generator: 

 On the Data Entry toolbar, click Load Combinations. 
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The Load Combination spreadsheet will display: 

 

This spreadsheet contains two default load combinations. To accurately generate all the appropriate 
combinations per the design code, you must first delete any load combinations currently in the 
spreadsheet: 

 On the Window toolbar, click Delete Line  two times to delete both rows (or use the shortcut 
by pressing the F4 key two times). 

Now, generate the load combinations: 

 On the Window toolbar, click LC Generator . 

 In the Region list, click United States. In the Code list, click 2015 IBC Strength. 

 Under Wind Load Options, click None.  

 Under Seismic Load Options, click None.  

Note: These are specified as none because you have not applied any loads in these categories. 

 

Verify the dialog box settings, then generate: 

 Click Generate. 
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The spreadsheet contains 7 load combinations and looks like this (you may need to resize the 
spreadsheet to view them all): 

 

Generate additional load combinations, this time specifying a different code: 

 On the Window toolbar, click LC Generator  again. 

 In the Load Combination Code list, click 2015 IBC ASD. 

 Click Generate. 

The new load combinations will be appended to the 7 previously generated. Now, your Load 
Combinations spreadsheet contains 15 combinations, as shown below. 

 

Close the spreadsheet and return to the model view: 

 Click Close . 

Loads Display 

Until this point, you have been able to view your loads graphically, but you have only seen them 
displayed by load category. RISAFoundation also allows you to view your loads by load combination. This 
option allows you to view your loads, as magnified or reduced per your multiplying factors. 

The Loads Display buttons help view the load categories and load combinations, as shown below: 
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Experiment by “switching” to display load combinations (instead of categories): 

 On the Window toolbar, click Switch Loads . Notice that the Loads List will now change to 
display the 15 load combinations you generated earlier. 

Now, display one of the load combinations: 

 On the Selection toolbar, click Select All . 

 On the Window toolbar, in the Loads List, click LC 13: IBC 16-11(a).  

 

Your model view will show the displayed loads, as multiplied by the load combination factors in the 
model view. 

 

This is the end of Tutorial A3. 

You can save your model to be used as the starting point for the next tutorial, or begin the next tutorial 
using the .fnd starter file in the RISAFoundation Tutorials folder. To save the model: 

 Select Save As from the File menu. Enter in a file name and click Save. 
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Part A: Tutorial 4 – Solving & Results 

Overview 

The last step in the modeling process is to solve the model and review the results. RISAFoundation 
presents results in several ways. You may view the data in the spreadsheets, view a member detail 
report, or view the results graphically.  

Getting Started 

This tutorial continues where the previous tutorial ended, so follow these steps to get your model up 
and running: 

If you are continuing from the previous tutorial: 

 On the Main menu, select Single View from the Window menu. 

 On the Window toolbar, click the Graphic Editing Toolbar button  to activate the Drawing 
toolbar. 

 Skip ahead to the next section titled Solve the Model. 

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA : 

 Double-click the RISAFoundation icon to start the program. 

 Click Open File  from the Starting a Model dialog box.  
Double-click the Model Files folder then the Tutorials folder, select Tutorial A4 Starter.fnd and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the Window toolbar, click the Graphic Editing Toolbar button  to activate the Drawing 
toolbar. 

Your screen should now look like this: 
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Solve the Model 

Start by solving the model. 

 On the RISA toolbar, click Solve . 

When the solution is complete, two new items will display: the Results toolbar and the Warning Log 
spreadsheet: 

 

The two warnings associated with this model are in reference to a limitation in the pedestal design. 
These can be ignored because, while they limit the design checks performed by the program, they do 
not cause erroneous results in the design checks that were completed.  

 Click Close  to close the Warning Log spreadsheet. 

Slab Results 

When your model is solved, slab elements are automatically submeshed into plate elements. Therefore, 
RISAFoundation displays two plate result spreadsheets: Plate Forces and Plate Corner Forces. Review 
the data in both spreadsheets to get specific force data for each submeshed plate: 

 On the Results toolbar, click Plate Forces. 

 On the Results toolbar, click Plate Corner Forces. 

Notice that both spreadsheets are organized by Load Combination and then by Plate Label. To view the 
results by Plate Label and then Load Combination, change your Application Settings: 

 On the Tools menu, click Application Settings. Click the Solution and Results tab. 

 Click Batch results displayed by ITEM.  

The Results toolbar 
contains links to 
each of the results 
spreadsheets.  

The Warning Log 
spreadsheet reports the 
various warnings related to 
your solution. 
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Verify the settings, then accept the changes: 

 Click OK. 

Briefly review several of the other results spreadsheets. 

 On the Results toolbar, click Point Reactions. 

 On the Results toolbar, click Point Deflections.  

When you are finished reviewing the spreadsheets, close the spreadsheets and return to the original 
model view: 

 On the Window menu, click Single View. 

Design Strips 

Design strips are used to create design regions within a slab. Each design strip will contain automatically 
defined design cuts which will control the reinforcement design for that design strip. The results for the 
entire design strip will be determined by the maximum moment demand of the governing design cut 
within that design strip. Because one governing design cut controls the entire design strip, it is critical 
that good engineering judgment is used to determine an appropriate width for the design strip. 

You will draw design strips under your two line loads, as this is the most likely place for maximum 
moment. Because the design strip designs reinforcement in only one direction, you must add at least 
two strips: one in each direction. 

Start by turning off the loads and point labels: 

 From the View menu, click Loads. 

 From the View menu, click Point Labels. 

Now draw your Design Strip. 

 On the Selection toolbar, click Design Strip .   

If this parameter is selected, the 
spreadsheet will list the results by ITEM. 

All other spreadsheets will reflect the 
change (it is not necessary to perform 
another solution). 
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First, draw the strip to design the horizontal (Z axis direction) reinforcement: 

 Under Rebar Orientation, click Plan Horizontal. 

 

Verify the settings, then accept the changes: 

 Click Apply. 

You will enter the drawing mode. Draw the strip by clicking the following grid intersections (you may 
need to zoom in a bit and reposition your model view so that you can see the entire area): 

 Click grid intersections D1, D9, C9, C1, then close the strip by clicking D1 again.  

Note: To close off the strip perimeter, you must make your last click the same as your first (D1); or, you 
can double click the last point in the strip (C1). 

This strip will display with the reinforcement design as the labeling. 
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Next, draw the second strip in the perpendicular direction: 

 On the Selection toolbar, click Design Strip  (or press CTRL+D to recall the last dialog 
box). 

 Under Rebar Orientation, click Plan Vertical. 

 In the Design Cuts Per Strip box, type 50. 

 

Verify the settings, then accept the changes: 

 Click Apply. 

Draw the strip by clicking the following grid intersections:  

 Click grid intersections A2, I2, I4, A4, then close the strip by clicking A2 again.  

The strip will display perpendicular to the first strip: 

 

 Re-solve the model by clicking Solve  on the RISA toolbar.   
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A message will display notifying you that the results will be cleared: 

 

 Select Yes. 

Note: Whenever you solve the model, RISAFoundation will display a message notifying you that the 
results will be cleared (this alleviates the possibility of you having results data that does not match the 
input data). If you prefer to disable the warning message, you may do so in the Application Settings (on 
the Tools menu, click Application Settings). 

Now you can review the design data contained in the spreadsheets for the design strips. 

 On the Results toolbar, click Strip/Cut Results to open the Strip Reinforcing spreadsheet. 

The Strip Reinforcing spreadsheet will display: 

 

Note: Images and numbers shown are for reference only.  It is possible that you will see different results 
even if you only slightly used a different modeling procedure; therefore, the results screenshots shown 
in this Tutorial are only meant to be an example for exploring the results features. 
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Also, review the detail reports: 

 On the Window toolbar, click Detail Report for Current Item . 

This opens the Design Strip Detail Report where you can view the envelope force diagrams and the 
code check information. 

 

The Design Strip Detail Report also illustrates which Design Cut the governing design forces came from. 

 

 Select the Cut button to view the detail report for the governing Design Cut. 

Use the arrow buttons to quickly advance 
through the different design strips. 
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By selecting the Cut button, the governing Design Cut detailed report opens.  This is the cut that governs 
the Design Strip’s design. 

 

 Click Close  to close the Detail Report for Design Cut dialog. 

Using the Model Display Options allows you to confirm the location of the governing design cut with 
labels.  

 On the View menu, select Model Display Options. 

 Click the Design Strips/Cuts/Soil Regions tab. 

 Check the Show Auto Cuts check box. 

 Select Label option from the dropdown menu. 

 Click OK. 

This will now display the design cuts in the model view.  You may use this to validate the location of the 
governing Design Cut in the strip. 
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Close both the detail report, the spreadsheet and unselect the display of auto cuts: 

 On the View menu, select Model Display Options. 

 Click the Design Strips/Cuts/Soil Regions tab. 

 Uncheck the Show Auto Cuts check box. 

 Click OK. 

 On the Window menu, click Single View. 

Printing 

RISAFoundation offers several ways to display and print your results as follows: graphics printing, 
spreadsheet printing, and/or report printing.  

Graphics Printing 

Because RISAFoundation offers a number of ways to view your results graphically, you may want to print 
some of those views to view along with your spreadsheet results.  

Using Model Display Options, explore some of the ways you can quickly review your results on your 
model. 

 On the View menu, select Model Display Options.  
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This displays all the viewing options in RISAFoundation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Edit the Design Strips/Cuts/Soil Regions properties:  

 Click the Design Strips/Cuts/Soil Regions tab. 

 Uncheck the Show Design Strips check box. 

 Uncheck the Show Custom Design Cuts check box. 
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Edit the Slab properties:  

 Click the Slabs tab. 

 Under Show Slabs As, click Rendered. 

 

Edit the Deflection properties: 

 Click the Deflection tab. 

 In the Show Deflected Shape For section, click Load Combination (pick from list at bottom). In 
the Magnification Factor box, type 1000. 

 In the Combination To Use For Results Display list, click 6: IBC 16-3 (c). 

 

Verify the settings, then accept the changes: 

 Click OK.  
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If you have zoomed in, you may want to redraw to the full model view. Then, change the display an 
isometric view: 

 On the Window toolbar, click Redraw . On the Window toolbar, click Isometric . 

 Toggle off the loads view by clicking on the Toggle Load Display button  and the Joint Labels 

button . 

 

Now that you have your model in the correct view, print an image of this display to include with your 
report. 

 On the File menu, click Print. 

 In the Additional comments to include in the title bar box, type Deflected Shape. 

 

 Click Continue. 

The print dialog box for your printer will display. 

 Select your printer name and click OK. 
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Spreadsheet Printing 

You may also want to print information directly from a spreadsheet. Try this with the beam results.  

 On the Results toolbar, click Beam Results. 

 On the RISA toolbar, click Print  (shortcut: CTRL+P). 

 Click Print Current Spreadsheet. 

 

 Click OK. 

The print dialog box for your printer will display. 

 Select your printer and click OK. 

Report Printing 

Sometimes you may want to print multiple spreadsheets to create a model report. Rather than print 
each spreadsheet individually, you can create and print a report combining and sorting the output. 

 Click anywhere in the model view, making it the active window. 

 On the File menu, click Print. 

 Click Print a Report Instead. 

 

The Report Printing dialog box will appear. Specify the type of report you would like printed: 

 In the Report Name list, click Output. 
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Next, designate the criteria you would like included in your report: 

 In the Sections in Current Report list, double-click the following sections:  

Beam Section Forces 

Slab Overturning SF 

Slab Sliding SF 

Slab Soil Pressures 

Footing Soil Pressures 

Beam Soil Pressures 

Double-clicking these sections will remove them from the Sections in Current Report column (on the 
right) and place them in the Available Report Sections column (on the left).  
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Now you can print the report: 

 Click Create PDF and save the file.  

Close the Report Printing dialog box and the spreadsheets. 

 Click Close to close the Report Printing dialog window . 

 On the Window menu, click Single View. 

DXF Export 

Another useful tool that RISAFoundation provides is the ability to export a drawing of your foundation 
plan, footing details, or slab reinforcing to a DXF file. This can then be opened in any standard drafting 
software program. 

Now that your model is solved, you can utilize this export functionality to create some detailed 
drawings. 

 On the File menu, click DXF Export, then click Foundation Plot Plan. 

 In the File Name box, type Tutorial A4.dxf.  

 Click Save. 

The Export DXF File dialog box will display, which allows you to specify export options and control the 
naming of the DXF layers. 

 

 Accept the default names and click OK.  
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This will create a DXF of the foundation plot plan similar to the one pictured below: 

 

 

This completes Part A: Building From Scratch.  
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Part B: RISA-3D Integration 

Introduction 

This part (Part B) of the User’s Guide will demonstrate how to build a RISAFoundation model around 
loads imported from a RISA-3D model. With the guidance of these tutorials, you will open a RISA-3D 
model and import it into RISAFoundation, where you will build, solve, and modify a typical industrial 
foundation system comprised of several different types of foundations.  

The tutorials build upon themselves from start to finish. You have the option of performing all the 
tutorials at one time, or performing each one separately. To make this possible, RISA provides model 
files for you to load at the beginning of each tutorial. These starter files are located in My Documents 
folder in the RISA\Model Files folder under Tutorials, and are named Tutorial B2 starter.r3d, Tutorial B3 
starter.r3d, etc.  

When you finish all five tutorials, the final product will look like this: 
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To complete all five tutorials will take only a few hours. However, you can speed up the process even 
further if you skip the supporting text and perform only the action steps, which are indicated with 
diamond-shaped bullets, as shown below: 

 In order for you to achieve accurate results, it is important that you do not miss any of these 
action steps while performing the tutorials. 
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Part B: Tutorial 1 – Importing from RISA-3D 

Overview 

This first tutorial demonstrates how to import loads into RISAFoundation from an existing RISA-3D 
model. A basic knowledge of RISA-3D is helpful when performing the RISAFoundation tutorials. So, if you 
would like more information on RISA-3D operation, please refer to the RISA-3D User’s Guide. This 
document is available for download on the RISA  website: http://www.risa.com, click Downloads, then 
click Product Documentation. 

Opening a RISA-3D File 

Because you want to import your loads from an existing RISA-3D model (rather than enter them 
manually), start by opening the model in RISA-3D and reviewing the superstructure before importing 
into RISAFoundation: 

 Double click the RISA-3D icon to start the program. 

 Click the File Open button  from the Starting a Model dialog box. Double click the Model 
Files folder then the Tutorials folder, select Tutorial B1 Starter.r3d and click Open.  

 Click Close  (or Cancel) to close the Model Settings dialog box. 

Your screen should now look like this: 

 

Note: The appearance of your 
menus and toolbars may look 
slightly different than shown here, 
depending on your computer 
screen resolution and font sizes. 

http://www.risa.com/
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Assign Loads to Load Categories 

You have now opened a complete structural model in RISA-3D. In order to export the reaction forces 
from the model into RISAFoundation for foundation design, you will need to assign the loads to Load 
Categories and then solve at least one Load Combination. 

Start by assigning the Load Cases to Load Categories. 

 On the Spreadsheets menu, click Basic Load Cases. 

This will open the Basic Load Cases spreadsheet, as shown below: 

 

Notice that the dead, live, wind, and seismic load cases have been assigned to load categories (indicated 
by DL, LL, WLZ, ELZ, etc., in the Category column).  All loads must have a load category assigned to them 
rather than None, or they will not transfer into RISAFoundation during the import process. 

Note: Assigning basic load cases to load categories is not required for the RISA-3D solution; however, 
they must be assigned in order for the loads to be transferred into RISAFoundation. 

Close the Basic Load Cases spreadsheet: 

 Click Close . 
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Next, you must solve at least one load combination in order to calculate the reaction loads: 

 On the RISA toolbar, click Solve . 

The Solution Choices dialog box will display: 

 

Indicate the type of solution you want to perform: 

 Click Single Combination and select 1:ASCE 1 from the list. 

 Click Solve. 

After RISA-3D completes the analysis, it automatically presents you with the Joint Reactions 
spreadsheet. Feel free to browse through these results and any others before moving into 
RISAFoundation. 

You are now ready to export the model into RISAFoundation. Use the Director tool to export the model 
into RISAFoundation. 

 On the Director menu (upper right corner of the Main menu), click RISAFoundation. 

 

Your model will automatically be exported from RISA-3D into RISAFoundation.  

 Click Close  (or Cancel) to close the Model Settings dialog box. 

Note: Once in RISAFoundation, notice that the file name still has the .r3d extension. This is because, 
when you use the Director tool to transfer your model between RISA-3D and RISAFoundation, the 
exported file remains in the original RISA-3D format and the original file name is maintained--even after 
a number of changes have been made in RISAFoundation. Because of this, every time you want to 
reopen the file, you will need to perform the same steps you did in this tutorial: open it in RISA-3D, run a 
single solution, and then use the Director tool to export the model into RISAFoundation. 
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This is the end of Tutorial B1. 

You can continue on to the next tutorial, or exit RISAFoundation now, and resume Tutorial B2 later. If 
you would like to save the changes you made to the model: 

 On the File menu, click Save As. Enter a unique file name and click Save. 
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Part B: Tutorial 2 – Modeling  

Overview 

This tutorial will focus on drawing the foundation elements around the points (and point loads) brought 
in to RISAFoundation from your RISA-3D file. This tutorial will demonstrate how to model slabs, 
pedestals, footings, grade beams, and soil regions in RISAFoundation. 

Getting Started 

You may continue with the model created in the previous tutorial, or with the starter file located in the 
RISAFoundation Tutorials folder.  

If you are continuing from the previous tutorial: 

 On the Main menu, select Single View from the Window menu. 

 Open Model Settings by clicking on Settings from the Main menu. 

 Skip ahead to the next section titled Modeling.  

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA .  

Note: Remember that because these files were originally created within RISA-3D, they have an .r3d file 
name extension and must be first opened in RISA-3D, solved, and brought in to RISAFoundation using 
the Director tool. 

 Double-click the RISA-3D icon to start the program. 

 Click Open Model .  
Double-click the Model Files folder then the Tutorials folder, select Tutorial B2 Starter.r3d and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the RISA toolbar, click Solve  to solve the model. The Solution Choices dialog box will 
appear. Click Single Combination and select 1:ASCE 1 from the list. Click the Solve button. 

Now, import the RISA-3D model into RISAFoundation: 

 On the Director menu, click RISAFoundation. 
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Your model will automatically be exported from RISA-3D into RISAFoundation. Your model should now 
look like this: 

 

Model Settings 

Start by exploring the RISAFoundation Model Settings dialog box. 

 On the RISA toolbar, click Set Model Settings  to open the Model Settings dialog box if the 
dialog box is not already open. 

 Click the Solution tab. 
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The Solution parameters are described below: 

Mesh Size Controls the coarseness or fineness of the slab mesh when RISA auto-meshes 
slabs during a solution. 

Coefficient of 
Friction 

Defines the values used in the slab sliding check to calculate the resisting force 
against sliding. 

Max Iterations Controls the maximum number of iterations RISA will perform during a solution. 

Merge Tolerance Used as the maximum distance two points can be apart and still be merged 
together. It is also used when scanning for crossing members and for 
unattached joints along the spans of beams. 

Solver Specifies which solver to use. See  the Help menu for more information. 

Save As Defaults Saves all modified information on this tab as the default settings. 

Review the Design parameters of the Model Settings dialog box: 

 Click the Design tab. 

 

The Design parameters are described below: 

# Shear Regions Allows you to control the number of regions to be used when detailing 
a beam span. 

Region Spacing Incr. Used to increase or decrease the spacing of shear ties during design 
optimization. 
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Optimize Footings for 
OTM / Sliding 

Defines whether or not you want the program to optimize footings 
based on overturning and sliding. 

Min 1 Bar Dia Spacing 
(for Beams Only) 

Defines a minimum spacing of one bar diameter between parallel bars. 
Otherwise, RISA will default to a two-bar diameter or one-inch clear 
spacing (whichever is greater) to allow for lap splices and continue to 
maintain adequate spacing between parallel bars. 

Concrete Stress Options Defines the type of stress block to consider in your analysis. 

Concrete Rebar Set Defines which reinforcement standard set will be used in your design. 

Parme Beta Factor This value is used to approximate the column’s 3D interaction surface 
when using the PCA Load Contour Method. 

Code Defines the concrete/masonry/pile design code for your solution.   

Pile Safety Factor Allows you assign a safety factor for the design of piles. 

Specify which Concrete Stress Option and what design Code you would like considered in your analysis.  

 Under Concrete Stress Options, click Parabolic Stress Block. 

 Under Code, select ACI 318-14. 

 Click OK to save your settings and close the Model Settings dialog box. 

Modify the Drawing Grid 

Before you begin drawing your foundation elements, you will need to generate a drawing grid to assist 
you in your modeling. The drawing grid is different than your project grid (which was imported from 
RISA-3D, and displayed in blue). The drawing grid is independent of your model.  

First, toggle off the display of the loads and node labels for a better view: 

 Open the View menu from the Main menu toolbar and select Loads. 

 Repeat, this time selecting Point Labels. 
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Create a drawing grid for this model:  

 On the Modify menu, click Drawing Grid. 

 

Modify the drawing grid as follows: 

 Under Drawing Grid Origin, in the Z Axis and X Axis boxes, type 0.  

 Click Rectangular Grid Increments. In the first column under Z, highlight and delete any current 
data and type: 3@20. 

 In the first column under X, highlight and delete any current data and type: 2@20. 

  

The default settings (30@1 
in the Z and X directions) 
will create a 30’x30’ grid 
divided into 1’ increments.  

For this tutorial, you will 
redefine the drawing grid to 
facilitate the drawing of the 
slabs in the next step. 
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When finished, your dialog box should look like this: 

 

Review your edits, then proceed: 

 Click Ok. 

Notice the drawing grid now appears on the lower portion of your model: 

 

Now that you have your drawing grid in place, you are ready to draw your slab. 

Drawing Grid 
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Drawing Slabs 

You may draw a slab as one large polygon, or you may define smaller portions of the slab by drawing 
multiple polygons. If the border of your slab region aligns with an existing slab, the two slabs will be fully 
connected as if they were a single slab.  

Using the drawing grid you just created, draw a single slab: 

 On the Drawing toolbar, click Draw Slabs . (If the Drawing toolbar is not visible, press 
CTRL+G to turn it on.) 

This opens the Draw Slabs dialog box: 

 

For this tutorial, you will model a 30 inch, 4 ksi NW slab.  

 In the Material Set list, click Conc4000NW.  

 In the Thickness box, type 30. 

 Click Apply.  

Note: Your cursor changes to , indicating that you are now in slab drawing mode. To exit this mode at 
any time, right-click your mouse or press ESC. 

Notice that when your cursor passes over a grid intersection or a node, the coordinates are displayed on 
the Status Bar (on the lower right corner of your screen). Because the drawing grid does not have nodes 
at the grid intersections, you will need to use these coordinates to accurately draw your slab.  

 

  

Notice that the Material Set list 
contains six default materials.  

You may add additional 
materials by adding new entries 
in the Materials spreadsheet. 

Grid coordinates are 
displayed here. 
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Draw the polygon for the slab: 

 Click the following coordinates to draw the polygon: 
(0,0) 
(0,40) 
(60,40) 
(60,0) 
(0,0) 

When you are done, your model will look like this: 

 

Next, create the slabs representing your combined footings over gridlines PB, PC, and PD. Rather than 
manually enter the drawing grid to create new snap points for drawing, you will import a DXF drawing 
grid. 

  

If you make any 
mistakes, click 
Undo  or Redo 

 (located on 
the RISA toolbar). 

When you have finished the polygon, you 
may close it by clicking the first 
coordinate a second time (or you can 
simply double-click the final coordinate).  

To exit the drawing tool, right-click or 
press ESC to exit the drawing tool. 
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Select the DXF to import: 

 On the Modify menu, click Drawing Grid. Click the Import DXF tab. 

 

Browse to select the DXF file: 

 Click on the Browse for File button. 

 Browse to Documents\RISA\Model Files\Tutorials (or the location RISA was installed such as 
C:\RISA\Model Files\Tutorials) and select Footing Slab.dxf.   

 Click Open. 

Import all layers: 

 In the Select Layers for Drawing Grid dialog, select Use All Layers and then click Done. 
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Draw in the footing slabs using the new drawing grid: 

 Select  to re-open the Draw Slabs dialog. 

 

Verify that the dialog box settings are still the same as shown above, then apply: 

 Click Apply. You will now resume the drawing mode. 

Draw the three combined footing slabs: 

 Using the new drawing grid outline snap points, draw in the three new slabs along gridlines PB, 
PC, and PD, as shown in the next image. 

 Right-click your mouse, or press ESC to exit the drawing mode. 

When finished, your model should look like this: 

 

Three new 
footing slabs 
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Enlarging the Slab 

Our last step is to enlarge the bottom (large) slab so the edges of the slab are expanded 3 feet out in 
each direction.  We can easily do this using the Offset Slabs tool. 

 From the Drawing toolbar, click on the Modify Edges button . 

 Enter an Offset Distance of 3 ft. 

 

 Select Apply Entries by Clicking Slab Edges and click Apply. 

 Click on the bottom (large slab). 

You should now see that the edges of the slab have been moved out 3 feet along each side: 
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Drawing Pedestals 

Your next step is to draw pedestals on the slabs. To make this easier, start by turning off the display of 
the project grid and the Data Entry toolbar. Then, use the selection tools to select just the nodes on the 
lower slab. 

 On the Data Entry toolbar, click Close . 

 On the View menu, click Project Grid to turn off the Project Grid display. 

 On the Selection toolbar, click Unselect All  to unselect the entire model. Then, click Criteria 

Selection . 

The Select Items for Current View dialog box will display: 

 

Select only the nodes on the slab: 

 Click the Coordinates tab. 

 Under Coordinate Bounds, in the X Coordinate row, under Minimum, type 0, and under 
Maximum, type 40. 
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The dialog box should now look like this: 

 

Verify the dialog box settings, then apply: 

 Click OK. 

Now, only the nodes on the interior of the slab are selected: 
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Before you continue drawing, save this selected state so that you may access it later. 

 On the View menu, click Save or Recall Selection States. 

 Click Save. Enter the description Slab Pedestals. 

 Click OK. Then click Close. 

 

Finally, draw the pedestals: 

 On the Drawing toolbar, click Draw Pedestals . 

 Under Concrete Pedestal/Post, select Concrete Pedestal. 

 Under Shape/Size, click Rectangular. In the D box (for depth), type 24.  In the W box (for width), 
type 20. 

 In the Material Set list, click Conc4000NW. 

 

Verify the settings, then apply: 

 Click Apply. 

Note: Your cursor will change to , indicating that you are now in the pedestal drawing mode. To exit 
this mode at any time, right-click your mouse or press ESC. 
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To draw the pedestals, you may click each node individually--but you may find it much faster to “box” 
the nodes you just selected: 

 Draw a box around the selected nodes, as shown below: 

 

Exit the drawing mode, reselect the entire model, and turn on the project grid display: 

 Right-click the mouse (or press ESC) to exit the drawing mode. 

 On the Selection toolbar, click Select All  to reselect the entire model. 

 On the View menu, click Project Grid to turn on the project grid display. 

Then apply pedestals to your combined footings.  

 Press the PLUS SIGN (+) on your numeric keypad three times to zoom in. You may need to adjust 
the scroll bars (or use the panning technique) to position the combined footings in clear view. 

  

Once you draw the box (and 
release the mouse), notice that 
pedestal icons appear over all the 
nodes that were selected. 
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Your model view should look similar to this: 

 

Prepare to draw some more pedestals: 

 Press CRTL+D to recall the last dialog box (Draw Pedestals). 

 Under Concrete Pedestal/Post, select Concrete Pedestal. 

 Under Shape/Size, click Rectangular. In the D box (for depth), type 20. In the W box (for width), 
type 20. 

 

Verify the settings, then apply: 

 Click Apply. 
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Draw the pedestals, then return to full view: 

 Click the following grid locations to draw your pedestals:  
PB-1.1   PB-1.9 
PC-1.1   PC-1.9 
PD-1.1   PD-1.9 

 When finished, click Redraw  to return to the full view. 

Your model should look like this: 

 

  



Part B: Tutorial 2 – Modeling 

104 

 

Drawing Footings 

Next, you will draw your footings. First, enter the footing parameters and then apply that footing to a 
point (similar to how you would apply a boundary condition). 

To provide quick access to the spreadsheets, display the Data Entry toolbar. 

 On the RISA toolbar, click the Data Entry toolbar  button. 

 Then, on the Data Entry toolbar, click Footing Definitions. 

This opens a spreadsheet that contains all the design parameters for footing design. You may add rows 
to this spreadsheet to create as many footing designs as you like.  

 

Explore the contents of the spreadsheet. For now, you will use the default entries so, after reviewing, 
you may close the spreadsheet: 

 Browse through the various tabs in this spreadsheet and review the contents for Footing 1. 

 Then click Close . 

Note: To access help on a spreadsheet, click the F1 key while the spreadsheet is open. The Help menu 
will open directly to that topic. 

Now that you have defined your footing, apply it to your model. 

 On the Drawing toolbar, click Assign Footings/Supports/Piles . This dialog box allows you to 
apply either typical supports (Reaction, Spring, etc.), footings, or piles. 

 In the Assign Footing list, click Footing 1 to assign the footing you reviewed earlier.  

 

Verify the settings, then apply: 

 Click Apply.  

Notice that you can also apply a 
rotation angle to your footing 
(although for this model, you 
will use the default of 0 
degrees). 
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Note: The cursor will change to , indicating you are in footing drawing mode. 

Begin drawing the footings: 

 Click the following grid locations to draw the first two footings: 
PA-1.1   PA-1.9 

Similar to the method you used to draw pedestals on the lower slab nodes, use the “box” method to 
draw footings on the lower four nodes: 

 Box the four grids located near gridline PE (shown below). 

The clicking and boxing methods of drawing the footings are shown below: 

 

For a better view of your footings, render your model in color fill view: 

 On the Window toolbar, click Rendering . 

  

“Box” these four nodes 
to draw these four 
footings, as shown. 

Click on each of these two nodes 
to apply these two footings. 
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The color fill rendered model will look like this: 

 

You may now exit the drawing mode: 

 Right-click your mouse or press ESC exit the drawing mode. 
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Drawing Grade Beams 

To complete the strap footings, add in some grade beams. In RISAFoundation, beams are treated as 
physical members, in that the beams will provide fixity to all joints that occur along the span of the 
member. Therefore, it is not necessary to break up your beams into individual members to be able to 
connect them to intermediate elements. 

Start by drawing a beam:  

 On the Insert menu, click Beams. 

 In the Material Set list, click Conc4000NW.  

 In the Depth box, type 24, and in the Width box, type 18. 

 

Verify the settings, then apply: 

 Click Apply. You are now in beam drawing mode. 

Zoom in on the upper left portion of your model: 

 On the Window toolbar, click Zoom In . 

 Draw the first beam by clicking the following grid locations: PA-1.1 and PA-1.9. Right-click the 
mouse or press ESC to release the mouse. 



Part B: Tutorial 2 – Modeling 

108 

 

 

Draw a second beam. 

 Scroll down, so that you are now zoomed in on the middle of the model. 

 Draw the second beam by clicking the following grid locations: PE-1.1, then PE-1.9. Right-click 
the mouse or press ESC to release the mouse. 

 

  

Notice that your cursor remains 
attached to the node at R3D_N2. If 
you do not wish to continue drawing 
beams, right-click the mouse or press 
ESC to release the mouse. (Right-click 
or press ESC an additional time to exit 
the drawing mode completely.) 
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Now that you are finished drawing your beams: 

 Right-click your mouse or press ESC a second time to exit the drawing mode completely. 

 On the Window toolbar, click Redraw  to resize the model to full view. 

Your model should now look like this: 
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Soil Regions 

Soil definitions are provided in the Soil Definition Editor tool which can be accessed through the Soil 
Definitions spreadsheet.  This spreadsheet always contains at least one soil definition which acts as the 
default value.  The default value is considered to support the whole model unless you manually model 
differing soil regions. 

 From the Data Entry toolbar, click Soil Definitions. 

 

The soil definition parameters are described below: 

Subgrade Modulus Defines the global Subgrade Modulus magnitude to apply to the entire model. 
This can be overridden with a local soil region with a different Subgrade 
Modulus if you require varying soil types in your model. 

Allowable Bearing Defines the global Allowable Bearing Pressure magnitude to apply to the entire 
model. This can be overridden with a local soil region with a different Allowable 
Bearing Pressure if you require varying soil types in your model. 

Depth Properties The soil depth properties are used for static pile design of concrete, hot rolled, 
and wood piles. Clicking on the red arrow in a cell in this column will allow you 
to open the Soil Depth Properties spreadsheet for that soil definition. 

Default? Defines which soil definition is to be the default for the whole model. 

 Click Close to close the spreadsheet and return to the model view. 

Modifying Soil Regions 

Lastly, you will model a soil region. Because you want to establish an area with different soil properties 
than those set as the default in Soil Definitions (subgrade modulus and allowable bearing pressure), you 
will do so with the Draw Soil Regions tool: 

 On the Insert menu, select Soil Regions. 

 Click the box next to the Soil Definition label to access the Soil Definition Editor. 
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Create a new custom soil definition: 

 In the Label box, type Soil 2. 

 In the Subgrade Modulus box, type 140. 

 In the Allowable Bearing Pressure box, type 5. 

 

 Click OK. 

Verify the settings in the Draw Soil Regions dialog, then apply: 

 

 Click Apply. You are now in the soil region drawing mode. 

First turn the Point Labels back on: 

 Click on the Point Labels button  twice. 

Draw the soil region under the slab: 

 Click on the corner nodes of the bottom (large) slab: N37, N38, N39, N40, and N37 once more to 
close the polygon. 

Note: If you had drawn your soil region under just a portion of a footing, the footing would be designed 
for the soil type under the defining footing joint. They will not be designed for half one soil region, half 
another. However, if you model a soil region under a portion of a slab, the slab will be deisgned for half 
one soil region, half another. 
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This completes your initial foundation design. You may now review the rendered, isometric view of your 
model to ensure that everything looks correct: 

 On the Window toolbar, click Redraw  to redraw the model in full model view.  

 On the Window toolbar, click Isometric  to view the model in isometric view. 

 On the Window toolbar, click Rendering  one more time to view the full rendered view. 

 

 

 

 

This is the end of Tutorial B2. 

You can save your model to be used as the starting point for the next tutorial, or begin the next tutorial 
using the .r3d starter file in the RISAFoundation Tutorials folder. To save the model: 

 Select Save As from the File menu. Enter in a file name and click Save. 
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Part B: Tutorial 3 – Modifying 

Overview 

Now that you have completed your initial RISAFoundation model, it is inevitable that modifications or 
changes will need to be made. In this tutorial, you will explore one of the most powerful features of RISA 
software—the ability to quickly and effectively make changes to an existing model without having to 
completely redraw your model.  

Getting Started 

You may continue with the model created in the previous tutorial, or with the starter file located in the 
RISAFoundation Tutorials folder.  

If you are continuing from the previous tutorial: 

 On the Main menu, select Single View from the Window menu. 

 Skip ahead to the next section titled Modifying the Model.  

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA .  

Note: Remember that because these files were originally created within RISA-3D, they have an .r3d file 
name extension and must be first opened in RISA-3D, solved, and brought in to RISAFoundation using 
the Director tool. 

 Double-click the RISA-3D icon to start the program. 

 Click Open Model .  
Double-click the Model Files folder then the Tutorials folder, select Tutorial B3 Starter.r3d and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the RISA toolbar, click Solve  to solve the model. The Solution Choices dialog box will 
appear. Click Single Combination and select 1:ASCE 1 from the list. Click the Solve button. 

Now, import the RISA-3D model into RISAFoundation: 

 On the Director menu, click RISAFoundation. 

 Click Close  (or Cancel) to exit the Model Settings dialog box. 
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Your model will automatically be exported from RISA-3D into RISAFoundation. Your model should now 
look like this: 

 

 

Modifying the Model 

The first part of this tutorial will guide you through some of the basic graphical functions of the program. 
As you move towards building larger and more detailed models, it becomes necessary to manipulate the 
view of your model to ensure that it is modeled properly. This is made possible through 
RISAFoundation’s Window toolbar. The Window toolbar contains all the buttons to help you manipulate 
your graphic view of the model, including zoom, pan, and rotation functions: 
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Rotating 

The Rotate buttons  are used to rotate the model in respect to the global axes 
of the model. Be sure the global axes icon is visible in order to view model rotation in reference to these 
axes.  The global axes icon should be visable in the upper left corner of your model view. 

 

Experiment with some of the model manipulation tools: 

 On the Window toolbar, click each rotate button  a few times. 

 On the Window toolbar, click Isometric  for an isometric view. Then click the Rotate buttons 

 once again to see how the model rotates in isometric view.  

 When you are finished, click the Isometric  once more to bring your model back into 
isometric view. 

 

  



Part B: Tutorial 3 – Modifying 

116 

 

Zooming 

The zoom buttons are used to zoom in or zoom out of your model.  

 On the Window toolbar, click Zoom In  and Zoom Out  to see how they affect the model 
view. 

Another zoom button, the Box Zoom button  allows you to zoom in on a specific area by drawing a 
box around the area. Try this by first resuming a planar full model view, then box zooming the upper 
two footings of your model: 

 On the Window toolbar, click Plan  to return to an XZ planar view. Then, click Redraw  
to resume full model view.  

 On the RISA toolbar, click the Data Entry toolbar  button to close it. 

 On the Window toolbar, click Box Zoom . Then, using the mouse, draw a box around the 
upper two footings, as shown below. 

Box the upper two footings as shown below: 

 

If your mouse has a wheel, you can use it as a shortcut to zoom in and out by rolling the mouse wheel 
forward and/or backward. Practice this zooming technique: 

 Roll the mouse wheel forward and backward to zoom in and out. 

 On the Window toolbar, click Redraw  to resume full model view.   
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Panning 

With the mouse wheel, you will also be able to use RISAFoundation’s panning feature: 

 Simply press down the mouse wheel anywhere on your model, hold and drag to the desired 
location. RISAFoundation will drag or your model to the new location. 

When you are finished, return to the original, full model view:  

 On the Window toolbar, click Plan , then click Redraw . 

Your window should now look like this: 
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Multiple Views 

RISAFoundation provides the ability to display multiple views of your model using two powerful tools: 

Clone View  and New Model View . These tools allow you to keep your original model view 
(window) intact in one view, then create additional views to display different views of the model.  

 

Listed below are some scenarios in which you may want to use these tools: 

 To isolate specific parts of your model to see how those parts are affected by your 
modifications.  

 If you do not want to change your existing view, but need to view a different side of the model, 
simply open a new window to view the other side.  

 When viewing results, you can plot different results information in each view.  

 Clone View  is currently not shown on the toolbar.  To access this button go to Tools - 

Customize Toolbar.  Here you will find Clone View  as well as several other quick acess tools 
you can add to your toolbar by clicking on the applicable tool and Add. 

 

New Model View - opens a new window 
containing the current model view (but does 
not include any rendering or view 
modifications). 

Clone View - opens a new window containing 
the current model view (including any 
rendering or viewing changes you have made). 

Example 1. Notice the current model view 
is in XY view and rendered--the cloned 
view is identical. 

Example 2. Even though the original model 
view is rendered and in XY view, the New 
Model View opens in wireframe, isometric 
view (the RISAFoundation default view). 
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Note: Each view, whether created with Clone View or New Model View, is independent and can be 
rotated, rendered, zoomed, selected, etc., without affecting the other model views. However, any 
modeling changes you make in any view will be automatically updated in the other views. 

You will now explore this feature a bit. Before you create a new model view, turn the joint labels off, so 
you will be able to visually see the difference between this view and the newly created view: 

 On the Window toolbar, click Display Loads  to turn off the loads display.  

Then, click Joint Labels  to turn off the joint labels. 

Now, create a new model view: 

 On the RISA toolbar, click New Model View . 

Compare the two model views you now have open. On the newly created model view, notice the loads 
display and the node labels are turned on (even though you turned them off on the original window—

remember viewing changes are not reflected when using the New Model View  tool). 

 

Render your new model view, then compare again: 

 Click your cursor in the newly created model view to make sure it is the active window. 

 On the Window toolbar, click Rendering  two times to render the new model view.  

  

The new model view 
is now the active 
view.  To move back 
and forth between 
the views, click in the 
windows. Or, on the 
Window menu, 
select the view you 
want to make active. 
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Notice the original model view remains unchanged: 

 

Next, you will temporarily delete a footing from the new model view, so that you can see the effect on 
each view: 

 Make sure your newly created model view is the active window. 

 Press CTRL+G to open the Drawing toolbar. 

 On the Drawing toolbar, click Delete . 

The Delete Items dialog box will appear: 
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Specify the method you will use to delete the footing, then delete it: 

 Click Delete LOADS/ITEMS by Clicking Individually, then click Apply. 

 Click the footing on grid intersection PA-1.9 two times to delete it and the loads applied to it.  

Notice that this model change was automatically updated on the other model view. 

 

Since you want to keep this footing in your model, undo the last operation: 

 On the RISA toolbar, click Undo  two times to bring the footing and its loads back. 

 On the Window menu, select Single View to return to the original, full size view of your model. 

Your model should now look like this: 
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Selection Tools 

Model modifications are inevitable with every design. Now that you have experimented with several of 
the viewing options in RISAFoundation, you can now explore how those viewing options can be 
combined with the selection tools help you make those model modifications quickly and easily. 

In the previous tutorial, you used the Criteria Selection feature to save a selection state. You will now 
retrieve this saved state to modify your slab pedestals. 

 On the Selection toolbar, click Unselect All . 

 On the Selection toolbar, click Save/Recall Selection . 

This dialog box will appear: 

 

Any selections states you have saved will be displayed: 

 Select Slab Pedestals. 

 Then, click Retrieve. 

Now your model will show only the slab pedestals selected: 
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Turn off the loads display and the joint labels: 

 On the Window toolbar, click Display Loads  to turn off loads display. 

 On the Window toolbar, click Joint Labels  to turn off the joint labels. 

Next, modify the properties of the pedestals: 

 On the Window toolbar, click the Graphic EditingToolbar  (shortcut: CTRL+G) to turn on the 
Drawing toolbar if it is not already on.  

 On the Drawing toolbar, click Draw or Modify Pedestals  to reopen the Draw 
Pedestals/Posts on Slab dialog box. 

 Click the Modify Pedestals tab to access the modify options. 

Change the pedestals from 24”x 20” rectangular to 24” diameter circular pedestals. 

 Under Pedestal Shape and Dimensions, click Circular. Be sure to select the Use? check box on 
the right. In the D (diameter) box, type 24. 

 Under What happens when Apply is pressed?, click Apply Entries to All Selected 
Pedestals/Posts. 

 

 Click Apply. 

Your model view will resume. Verify that the 12 pedestals have been modified by zooming in for a closer 
view: 

 On the Window toolbar, click Box Zoom , then draw a box around the slab pedestals as 
shown on next page. 

  

Select the Use? check box to apply that 
parameter to your model. Any 
unselected Use? check boxes will be 
ignored. 
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Your box should look similar to this: 

 

Next, use the selection tools to modify the Footing Definitions and Design Rules and apply these to the 
various pedestals: 

 On the Window toolbar, click Redraw  to resume the full model view. 

 On the Selection toolbar, click Select All  to select the entire model again. 

 On the RISA toolbar, click the Data Entry toolbar  button to reopen the Data Entry toolbar. 

Now, create a new Design Rule to govern the reinforcement of the footings: 

 On the Data Entry toolbar, click Design Rules. 

This spreadsheet will appear. 

 

Edit the spreadsheet by changing the label for line 2: 

 In row 2, under Label, type Combined Footings. 
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Your spreadsheet should now look like this: 

 

Now that you have created your second Design Rule, modify the footing rebar. 

 On the same spreadsheet, click the Footing/Pile Cap tab. 

 In row 2, labeled Combined Footings, in the Top Bar column, select #5 from the list. 

 In row 2, labeled Combined Footings, in the Bottom Bar column, select #5 from the list. 

Note: When selecting cells in a spreadsheet, you may click directly in the cell or press the TAB to 
advance from cell to cell. 

When finished, your spreadsheet should match the image below: 

 

Close the spreadsheet: 

 Click Close . 

Next, create a new Footing Definition. 

 On the Data Entry toolbar, click Footing Definitions. 

This spreadsheet will open: 

 

 

 

Resizing columns: Some column headings are narrow, and the 
complete name is not visible.  

To lengthen a column, place your cursor on the bar to the right of 
the heading. When it changes to , click and drag to the right. 

Tip: To move around in a 
spreadsheet, click directly in a 
cell to make it active, or press 
the TAB key to advance from 
cell to cell. 
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While this first entry, Footing 1, is appropriate for the two footings below grid point PE, you will enter a 
second row to limit the size of those on grid points PA and PE. 

 Press ENTER to add a new row to the spreadsheet. This new row will be automatically labeled 
Footing 2.  

 In row 2, labeled Footing 2, in the Design Rules column, click the down arrow  to view the list 
of available rules. Select Combined Footings. 

 

Modify the geometric properties: 

 Click the Geometry tab to review the options for limiting the size optimization of the footings. 

 In row 2, labeled Footing 2, in the Max Thickness column, type 30. 

 Lastly, select the Force Square checkbox for line 2 (Footing 2). 

Your spreadsheet should now look like this: 

 

Close the spreadsheet: 

 Click Close . 

Now that you have finished creating your new Design Rules and Footing Definitions, you can now apply 
these to some of your footings. 

First, you will select the footings you want to modify. Since your model is currently entirely selected, it 
will save time to unselect the footings, then invert the selection (which will leave the footings selected, 
and everything else unselected). 

 On the Selection toolbar, click Polygon Unselect . 

 Draw a polygon around the slabs and footings on grid points 1.1 and 1.9. Double-click the final 
point to close off the polygon.  

  

If the columns are narrow, it may 
be helpful to lengthen some of 
the column headings so they are 
more clearly visible. 
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Draw the polygon similar to this: 

 

When finished, all the elements within the polygon will be unselected. 

 

Next, invert the selection. 

 On the Selection toolbar, click Invert Selection .  

Note: Your cursor changes to 
, indicating that you are in 

the polygon selection mode. 

To close off the polygon, 
double-click the last point. 
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Your selections will now be inverted. The ten pedestals are now selected and everything else is 
unselected: 

 

Lastly, unselect the grade beams using the line selection tool: 

 On the Selection toolbar, click Line Unselect . 

 Draw a line through the top grade beam to unselect it, as shown below: 

  

Note: Your cursor changes to 

, indicating that you are in 
the line selection mode. 
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Repeat for the lower grade beam, then render so that you can view the footings more clearly: 

 Draw a line through the lower grade beam, to unselect it.  

 On the Window toolbar, click Rendering . Then, click Redraw .  

The rendered, full model view should look like this: 
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Lastly, unselect the three slabs: 

 On the Selection toolbar, click Box Unselect . Your cursor will change and you will be in box 
selection mode. 

 Draw a box around the three slabs to unselect them. Right-click or press ESC to exit the selection 
mode. 
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When finished, your model should look like this: 
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Once you verify that only these footings are selected, you are ready to apply the footing designation and 
design rule you created earlier: 

 On the Drawing toolbar, click Assign Footings/ Supports/ Piles . 

 In the Assign Footing list, click Footing 2.  

 Under What happens when Apply is pressed?, click Apply Entries to All Selected Points. 

 

Verify the settings and apply: 

 Click Apply, then click Close. 

 

 

 

 

 

 

This is the end of Tutorial B3. 

You can save your model to be used as the starting point for the next tutorial, or begin the next tutorial 
using the .r3d starter file in the RISAFoundation Tutorials folder. To save the model: 

 Select Save As from the File menu. Enter in a file name and click Save. 
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Part B: Tutorial 4 – Loading  

Overview 

Although your RISA-3D importation already brought over a number of loads, this tutorial will explore the 
other ways to apply loads to your RISAFoundation model. You will then learn how to combine these 
loads in load combinations which will be used later (in Tutorial B5) for solution. 

Getting Started 

You may continue with the model created in the previous tutorial, or with the starter file located in the 
RISAFoundation Tutorials folder.  

If you are continuing from the previous tutorial: 

 On the Main menu, select Single View from the Window menu. 

 Skip ahead to the next section titled Apply Loads.  

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA .  

Note: Remember that because these files were originally created within RISA-3D, they have an .r3d file 
name extension, and must be first opened in RISA-3D, solved, and brought in to RISAFoundation using 
the Director tool. 

 Double-click the RISA-3D icon to start the program. 

 Click Open Model .  
Double-click the Model Files folder then the Tutorials folder, select Tutorial B4 Starter.r3d and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the RISA toolbar, click Solve  to solve the model. The Solution Choices dialog box will 
appear. Click Single Combination and select 1:ASCE 1 from the list. Click the Solve button. 

Now, import the RISA-3D model into RISAFoundation: 

 On the Director menu, click RISAFoundation. 

 Click Close  (or Cancel) to exit the Model Settings dialog box. 
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Your model will automatically be exported from RISA-3D into RISAFoundation. Your model should now 
look like this: 
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Apply Loads 

Load Categories 

To verify that your loads imported properly from RISA-3D, review the Load Categories spreadsheet. In 
RISAFoundation, all applied loads must be assigned a load category. These are then listed in the Load 
Categories spreadsheet. 

 On the Spreadsheets menu, click Load Categories. 

 

Note: All loads from RISA-3D import into RISAFoundation as unfactored point loads. In other words, the 
load magnitudes are independent of the load combination(s) run in RISA-3D, and they are sorted only by 
category. When solving in RISAFoundation, this allows you to apply the full load magnitude when 
running your foundation-specific load combinations.  

Although this spreadsheet only lists the number of each load type applied to each category, you can 
click an item to “link” to a more detailed load spreadsheet. There you can review the specific location, 
direction, and magnitude of your loads. 

Try clicking the WLX entry to open the Point Loads spreadsheet: 

 In row 5, labeled WLX, in the Point Loads column, click 77. 

  

This spreadsheet displays the number 
of each type of load that was imported 
from RISA-3D. This may be used to 
verify that all loads were imported, 
and that they are assigned to the 
appropriate categories. 
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This automatically opens the Point Loads- Wind Load X spreadsheet: 

 

Review the Point Loads- Wind Load X spreadsheet, then close both spreadsheets: 

 Scroll down to review the point load location Label, load Direction, and load Magnitude 
information. 

 Click Close  to close the Point Loads spreadsheet. 

 Click Close  to close the Load Categories spreadsheet. 

Area Loads 

In addition to the point loads that were imported, draw some additional area loads over the slab. 

 Press CTRL+G to open the Drawing toolbar (if it is not already open). 

 On the Drawing toolbar, click Draw Area Loads . 

  

Click an item to “link” to and 
open a more detailed 
spreadsheet. 
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The Draw Area Loads dialog box will display: 

 

Enter the values representing the slab overburden. 

 Under the Uniform tab, in the Load Category Code list, select DL-Dead Load (if not already 
selected). 

 In the Base Mag box, type 0.1.  

 Click Apply and you are ready to draw your additional load. 

To make it easier to draw the load, first select only the corner nodes of the slab: 

 On the Selection toolbar, click Unselect All . Then, click Selection Criteria .  

 Click on the Supports/Beams tab. 

 In the Point Selection Criteria section, select the Use? check box on the right. 

 Under Point Range, in the From box, type N37. In the To box, type N40. 

 

Verify the settings, then apply: 

 Click OK. 

Note: Unlike RISA-3D, the positive 
vertical direction in RISAFoundation is 
assumed to be downward. Therefore, 
to apply a downward force, simply 
enter a positive magnitude. 
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Note: Your cursor changes to , indicating that you are now in drawing mode. To exit this mode at any 
time, right-click your mouse or press ESC. 

Now you are ready to draw the load: 

 On the Window toolbar, click Joint Labels  to turn them on (if they are not already on). 

 Click the following nodes: N37, N38, N39, then double-click N40. 

 Right-click your mouse or press ESC to exit the drawing mode. 

 On the Selection toolbar, click Select All  to select the entire model again. 

The graphic view of the model will now show hatch marks over the slab indicating the area load. If this 

does not show, you may need to (on the Window toolbar) click Display Loads . 
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You can also review the Load Categories spreadsheet once more to ensure the area load was applied 
properly to the DL-Dead Load category. 

 On the Data Entry toolbar, click Load Categories. 

 

Once you have verified the load was properly applied: 

 Click Close  to close the spreadsheet. 

Load Combinations 

Now that you have completed reviewing and applying your loads, you can combine them with 
multiplying factors to create load combinations. You can create these load combinations by either typing 
them into spreadsheets manually, or generating them automatically using the load combination 
generator. 

For this tutorial, generate the Load Combinations automatically: 

 On the Spreadsheets menu, click Load Combinations. 

This opens a blank spreadsheet.  You may choose to click ENTER and manually enter your load 
combinations, or you may use the Load Combination Generator, as we will do next: 

 On the Window toolbar, click LC Generator . 

Specify the type of loads you want to generate:  

 In the Region list, click United States as your Region. 

 In the Code list, click 2015 IBC Strength. 

 Under Wind Load Options, click X + Z with Eccentric. 

 Under Seismic Load Options, click X + Z with Eccentric, as these categories were automatically 
assigned by the Wind and Seismic Load Generators in RISA-3D. 

  

The 1 in this column 
indicates that you have now 
successfully added 1 Area 
Load to your DL Category. 
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The LC Generator dialog box should now look like this: 

 

Verify the settings and generate: 

 Click Generate. 

Notice that this creates 73 load combinations. However, many of these can be deleted since snow loads, 
rain loads, hydrostatic loads, and roof live loads do not apply to this model. Delete the load 
combinations that do not apply: 

 Click the first cell of row 3, labeled IBC 16-2 (b).  

Now active, this cell should be highlighted in green. 

 

Delete this row and the one underneath it:  

 Press the F4 key two times to delete rows 3 and 4, labeled IBC 16-2 (b) and IBC 16-2 (c). 

After you delete these two rows, notice that the remaining rows move up and are automatically 
renumbered.  
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Next, you will delete rows 10 through 23. Instead of using the F4 key to delete them one by one, try this 
method to delete them all at once. First, select the rows to be deleted: 

 Select rows 10 – 23, labeled IBC 16-3 (c) through IBC 16-3 (f) (f). Select the rows by clicking 
directly on row 10 (the row label), then drag down to row 23. Release the mouse. 

 

Once the rows are selected (and highlighted in yellow), delete the rows: 

 On the Window toolbar, click Delete Lines . The remaining rows will move up again. 

 Repeat this procedure to delete rows 16-27, labeled IBC 16-4 (b) (a) through 16-4 (c) (f). 

 Repeat this procedure to delete rows 28-39, labeled IBC 16-6 (b) (a) through IBC 16-7 (a) (f). 

  

Click the 
row label 
to highlight 
the entire 
row. 

Then hold 
and drag 
down to 
highlight 
the other 
rows. Note: The selected rows should be 

highlighted in yellow. If they are magenta, 
you have inadvertently selected cells from 
within the spreadsheet—not the row label. 
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When finished, you should have 33 load combinations remaining, as shown below: 

 

Finally, use the LC Generator again to generate your service level load combinations: 

 On the Window toolbar, click LC Generator again. 

 In the Code list, click 2015 IBC ASD. Click Generate. 

Once the spreadsheet opens with the generated load combinations:  

 Repeat the highlight and delete procedure for rows 36-38, labeled IBC 16-10 (a) through IBC 16-
10 (c). 

 Then delete the following load combinations:  
Rows 37-38: IBC 16-11 (b) through IBC 16-11 (c),  

Rows 55-66: IBC 16-13 (b) (a) through IBC 16-13 (c) (f), 

Rows 61-72: IBC 16-14 (b) (a) through IBC 16-14 (c) (f),  

Rows  67-72: IBC 16-15 (b) (a) through IBC 16-15 (b) (f), and 

Rows 73-78: IBC 16-15 (d) (a) through IBC 16-15 (d) (f). 

When finished, your spreadsheet should contain 72 load combinations: 

 Click Close  to close the spreadsheet. 
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Displaying Loads Graphically 

RISAFoundation provides simple ways to view your loads using the loads display buttons 

 located on the Window toolbar.  

 

 

Experiment with these buttons by switching to display the load combinations: 

 On the Selection toolbar, click Select All . 

 On the Window toolbar, click the Switch Loads button  once. 

 On the Window toolbar, click the Loads List , then select LC 10: IBC 16-4 

(a)(a) from the list. If the loads do not appear on your model, click Display Loads  to turn 
them on.  

  

The loads can be  
displayed as: 

Load Combinations 

Load Categories 

Switch Loads  – Alternates 
between the two display modes 
shown here 

Loads List – Lists available loads 

Display Loads  – 
Turns the display of 
loads on and off 



Part B: Tutorial 4 – Loading 

144 

 

Using these tools, you will be able to view the displayed loads graphically, as multiplied by the load 
combination factors. 

 

 

 

 

 

 

 

This is the end of Tutorial B4. 

You can save your model to be used as the starting point for the next tutorial, or begin the next tutorial 
using the .r3d starter file in the RISAFoundation Tutorials folder. To save the model: 

 Select Save As from the File menu. Enter in a file name and click Save. 
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Part B: Tutorial 5 – Solving & Results  

Overview 

The last step is to solve the model and review the results. RISAFoundation presents results in several 
ways. You may view the data in the spreadsheets, view a member detail report, or view the results 
graphically. You will explore all of these options in this final tutorial. 

Getting Started 

You may continue with the model created in the previous tutorial, or with the starter file located in the 
RISAFoundation Tutorials folder.  

If you are continuing from the previous tutorial: 

 On the Main menu, select Single View from the Window menu. 

 Skip ahead to the next section titled Solve the Model.  

-OR- If you are starting here from scratch, follow the steps below to load the starter file provided by 
RISA .  

Note: Remember that because these files were originally created within RISA-3D, they have an .r3d file 
name extension, and must be first opened in RISA-3D, solved, and brought in to RISAFoundation using 
the Director tool. 

 Double-click the RISA-3D icon to start the program. 

 Click Open Model .  
Double-click the Model Files folder then the Tutorials folder, select Tutorial B5 Starter.r3d and 
click Open.  

Click Close  (or Cancel) to exit the Model Settings dialog box.  

 On the RISA toolbar, click Solve  to solve the model. The Solution Choices dialog box will 
appear. Click Single Combination and select 1:ASCE 1 from the list. Click the Solve button. 

Now, import the RISA-3D model into RISAFoundation: 

 On the Director menu, click RISAFoundation. 

 Click Close  (or Cancel) to exit the Model Settings dialog box. 
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Your model will automatically be exported from RISA-3D into RISAFoundation. Your model should now 
look like this: 

 

Solve the Model 

Start by solving the model in RISAFoundation: 

 On the RISA toolbar, click Solve . 

Upon solution, you will be presented with the Results toolbar.  The Results toolbar displays on the top 
right of your screen, just above the Data Entry toolbar.  It provides quick access to each of the results 
spreadsheets. 

Turn off the view of the Loads for a clearer view: 

 Click on the View menu and select Loads. 
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Slab Results 

When your model is solved, slab elements are automatically submeshed into plate elements. 
RISAFoundation then displays two plate results spreadsheets: Plate Forces and Plate Corner Forces. You 
can review the data in each of these to obtain specific force data for each submeshed plate. 

 On the Results toolbar, click Plate Forces. 

 On the Results toolbar, click Plate Corner Forces. 

Notice that these spreadsheets are organized by Load Combination and then by Plate Label. To view the 
results by Plate Label first, and then Load Combination, change your Application Settings: 

 On the Tools menu, click Application Settings. 

 Click the Solution and Results tab. 

 Click Batch results displayed by ITEM. 

 

Once you click OK, your results will be grouped by Plate Label: 

 Click OK. 

Note: You can change your preference settings at any stage of your modeling process and the 
spreadsheets will automatically be updated—a re-solve is not necessary. 

Briefly review several of the other results spreadsheets, this time access them on the Results menu: 

 On the Results menu, click Point Deflections.  

When you are finished reviewing these spreadsheets, close the extra windows and return to the original 
model view: 

 On the Window menu, click Single View. 
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Design Strips 

Design strips are used to create design regions within a slab. Each design strip will contain automatically 
defined design cuts that will control the reinforcement design for that design strip. The results for the 
entire design strip will be determined by the maximum moment demand of the governing design cut 
within that design strip. Because one governing design cut controls the entire design strip, it is critical 
that good engineering judgment is used to determine an appropriate width for the design strip. 

Because the design strip designs reinforcement in only one direction, you must enter at least two strips--
one in each direction. 

 Near the bottom of the Selection toolbar, click the Design Strip button .  

The Draw Design Strips dialog box will appear: 

 

First, draw the strip to design the horizontal (Z axis direction) reinforcement. 

 Under Rebar Orientation, click Plan Horizontal. 

 In the Design Cuts per Strip box, type 50. 

 Click Apply. 

Turn off the load display to get a better view of the slab area, then draw the strip: 

 On the Window toolbar, click Display Loads . 

 Click the following grid intersections to define the strip: 
VC-1.0, VA-1.0, VA-4.0, double-click VC-4.0 to close the strip 

Note: To close off the strip perimeter, either: (1) double-click the last point (VC-4.0); or (2) make your 
last click the same as your first (VC-1.0). 
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Zoom in on the slab for a better view of the design strip: 

 On the Selection toolbar, click Box Zoom  and zoom in on the slab. 

Box the slab as shown below. This strip will display on your model with the reinforcement design as the 
labeling: 

 

Next, draw the second strip in the perpendicular direction. 

 Press CTRL+D to recall the last dialog box. 

 Under Rebar Orientation, click Plan Vertical. 

 In the Design Cuts per Strip box, type 50. 

 

 Click Apply. 

 Click the following grid intersections to define the strip: 
VC-2.0, VA-2.0, VA-3.0, double-click VC-3.0 to close the strip.  



Part B: Tutorial 5 – Solving & Results 

150 

 

Your two new design strips should look like this: 

 

 Click on Solve  from the RISA toolbar to re-solve your model. 

 A message will display notifying you that the results will be cleared. Select Yes. 

Note: Whenever you solve the model, RISAFoundation will display a message notifying you that the 
results will be cleared (this alleviates the possibility of you having results data that does not match the 
input data). If you prefer to disable the warning message, you may do so in the Application Settings (on 
the Tools menu, click Application Settings). 

Now you can display the detail reports of these strips to review the design data: 

 On the Results toolbar, click Strip/Cut Results. 

The Strip Reinforcing spreadsheet will display. 

 

Next, open the Design Strip Detail Report: 

 On the Window toolbar, click the Detail Report for Current Item button. 

This report allows you to view the envelope force diagrams and the code check information. 
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When you are finished, close both the Detail Report and the spreadsheet: 

 On the Window menu, click Single View. 

Turn off the Loads and Point Labels for a clearer view: 

 Click on the View menu and select Loads. 

 Click on the View menu and select Point Labels. 

Printing 

RISAFoundation offers several ways to print your results: graphically, individual spreadsheets, or 
combined reports.  

Graphics Printing 

Because RISAFoundation offers a variety of ways to view your results graphically, it can be beneficial to 
print those views along with your spreadsheet results. Start by exploring some of the ways to quickly 
review your results on your model: 

 On the View menu, click Model Display Options.  

  

Use the the arrow buttons  to 
quickly advance through the different 
design strips in the detail report. 
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This displays the Model Display Options dialog box which gives you access to all the viewing options in 
RISAFoundation: 

 

 

Start by modifying the design strips/cuts/soil regions parameters:  

 Click the Design Strips/Cuts/Soil Regions tab. 

 Uncheck the Show Design Strips check box. 

 Uncheck the Show Custom Design Cuts check box. 

 

Note: it is not necessary 
to click OK or Apply until 
completely finished 
editing all tabs on the 
dialog box. 
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Render the slabs: 

 Click the Slabs tab. 

 Under Show Slabs As, click Rendered. 

 

 

Modify the deflection settings: 

 Click the Deflection tab. 

 Under Show Deflected Shape For, click Load Combination (pick from list at bottom). Also, in the 
Magnification Factor box, enter 1000. 

 In the Combination To Use For Results Display box, select 16: IBC 16-5 (a). 
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Execute the changes and close the dialog box: 

 Click OK. 

View the model in isometric view: 

 On the Window toolbar, click Isometric  to view the model in isometric view.  

 On the Window toolbar, click Redraw  to view the full model view. 

Your model should now look like this: 

 

Now that you have your model in the correct view, you can print an image of this display to include with 
your report. 

 Right-click your mouse anywhere on the graphic, and click Print. 
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The Graphic Print Options dialog box will appear: 

 

You may specify a title or comment to be included in the title bar: 

 Select the Draw the title bar? check box (if it is not already selected). 

 In the Additional Comments to include in the title bar, type Deflected Shape. 

 Click Continue. 

Your normal print dialog box will appear (specific to your computer): 

 Select your printer and print. 

Spreadsheet Printing 

You may also want to print information directly from a spreadsheet. You can open and review any 
spreadsheet and print its results. Try this with the beam results: 

 On the Results toolbar, click Beam Results. 

 Press CTRL+P. 

The Data Printing dialog box appears: 

 

Make your data printing selections: 

 Click Print Current Spreadsheet. 

 Click OK. 
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Your normal print dialog box will appear (specific to your computer): 

 Select your printer and click OK to print the spreadsheet. 

Close the spreadsheet: 

 Click Close . 

Report Printing 

Many times, you will want to print multiple spreadsheets to create a model report. Rather than print 
each spreadsheet separately, you can opt to print a report. 

 On the File menu, click Print. 

The Graphic Print Options dialog box appears: 

 

Specify that you would like a report printed: 

 Click Print a Report Instead.  
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The Report Printing dialog box will appear: 

 

 

Specify the type of report you would like printed: 

 In the Report Name list, click Output. 

Next, designate the criteria you would like included in your report: 

 In the Report Sections area, under Sections in Current Report, double-click the following 
sections:  

Beam Section Forces 

Slab Overturning SF 

Slab Sliding SF 

Slab Soil Pressures 

Footing Soil Pressures 

Beam Soil Pressures 

Double-clicking these sections will remove them from the Sections in Current Report column (on the 
right) and place them in the Available Report Sections column (on the left).  
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Now you can print the report: 

 Click Print and select your printer.  

This will create a printed report containing all the sections listed in the Sections in Current Report 
column. When finished, close the Report Printing dialog box and the Beam Forces spreadsheet. 

 Click Close  to close the Report Printing dialog box. 
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DXF Export 

Another useful tool that RISAFoundation provides is the ability to export a drawing of your foundation 
plan, footing/pedestal/pile details, or slab reinforcing to a DXF file. This can then be opened in any 
standard drafting software for drafting purposes. 

Now that your model is solved, utilize this export functionality to create some detailed drawings: 

 On the File menu, click DXF Export, then click Foundation Plot Plan. 

 In the File Name box, type: Tutorial B5.dxf. Click Save. 

This Export DXF File dialog box displays. Here you can specify DXF options and naming conventions for 
the DXF layers. 

 

Accept the default settings and names: 

 Click OK. 
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This will create a DXF of the foundation plot plan similar to the image below. 

 

This completes Part B: RISA-3D Integration. 

 

Conclusion 

Congratulations on completing your introductory tour of RISAFoundation! The time you invested in 
performing these tutorials is time well spent. We are confident that the knowledge gained by taking the 
time to step through these tutorials will increase your productivity, and allow you to complete future 
projects more quickly and efficiently. 

If you have any questions or comments, please contact us by phone at (800) 332-7472 or email at 
info@risa.com. 

mailto:info@risa.com
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Appendix A – RISAFoundation Toolbar 
Button Quick Reference 

RISA Toolbar 

 

 

Button Title Label in RISAFoundation Shortcut 

 New Model  
Start a new model 

Start a new model (CTRL+N) 

 Open Model  
Open an existing model 

Reload from disk a 
previous model 

(CTRL + O) 

 Save  
Save current model to disk 

Save the current model 
data to disk 

(CTRL+S) 

 Copy  
Copy to the clipboard 

Copy to the clipboard (Ctrl+C) 

 Print  
Print a report or graphic image 

Print a report or graphic 
image 

(Ctrl+P) 

 Undo  
Undo the last operation 

Undo the last operation (Ctrl+Z) 

 Redo  
Reverse the most recent undo 
operation 

Reverse the most recent 
undo operation 

(Ctrl+Y) 

 Model Settings  Set Model Settings  

 Define Units  
Define units to be used 

Define units to be used  

 Rebar Layout  
Create and edit a custom rebar 
layout 

Create and edit a custom 
rebar layout 

 

 Project Grid  
Open the Project Grid spreadsheet 

Opens the Project Grid 
spreadsheet 

 

 Template  
Create a circular slab from a 
template 

Create a circular slab 
from a template 
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 New Model View  
Create a new model view 

Create a new model view (CTRL + F2) 

 Open Spreadsheets  
Select spreadsheets to open 

Select spreadsheets to 
open 

 

 Refresh  
Refresh all windows with current 
data 

Refresh all open windows 
with the most current 
data 

 

 Load Combinations  
Open the load combinations 
spreadsheet 

Open the Load 
Combinations 
Spreadsheet 

 

 Solve  
Perform the analysis and design 
calculations 

Perform the analysis and 
design calculations 

(F7) 

 Browse Results  
Select results to browse 

Select results to browse  

 Erase Results  
Erase all solution results 

Erase all solution results  

 Data Entry toolbar  
Turn the spreadsheet shortcuts 
menu on or off 

Turn the Spreadsheet 
Shortcuts menu off or on 

 

 Results toolbar  
Turn the results shortcuts menu 
on or off 

Turn the Results 
Shortcuts menu off or on 

 

 Help  
View help topics 

View Help menu topics (CTRL + F1) 
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Window Toolbar  

…in Model View  

 

Button Title Label in RISAFoundation Shortcut 

 Model Display Options  
Display Model Display Options 

Bring up the Model Display Options dialog  F2 

 Save Model View as Image  This button will allow you to save the 
current model view as a .PNG image that 
you can later include with your results 
report 

 

 Rotate buttons 

 

Rotate the view counter-clockwise about 
the X axis 

 

  Rotate the view clockwise about the X axis  

  Rotate the view counter-clockwise about 
the Y axis 

 

  Rotate the view clockwise about the Y axis  

  Rotate the view counter-clockwise about 
the Z axis 

 

  Rotate the view clockwise about the Z axis  

 Isometric  
Display an isometric view 

Snap to an Isometric View  

 Plan  
Display an XZ planar view 

Snap to an XZ Planar View  

 3 buttons below are collectively 

called Zoom buttons  

  

 Zoom In  Zoom IN (closer view) on the model  PLUS (+) 

 Zoom Out  Zoom OUT (view farther away) on the 
model  

MINUS (-) 

 Box Zoom  Draw a box around the part of the model 
to be zoomed 
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 Redraw  
Redraw full model view 

Redraw full model view  

 Graphic Editing  
Activate the Graphic Editing (AKA 
Drawing) toolbar 

Activate the Graphic Editing (Drawing) 
toolbar 

Ctrl+G 

 Save or Recall View  
Save or recall view states 

Save or recall view states  

 3 buttons below collectively refer 
to Loads Display  

 

  

 Display Loads  
Toggle display of the loads (LC or 
CAT) 

Toggle display of the loads (LC or CAT)  

 Loads List – lists the available 
loads 

 

  

 Switch Loads  
Switch loads display 
(combinations or categories) 

Switch loads display between 
combinations and categories 

 

 Rendering  
Toggle between wireframe and 
rendering of beams and plates 

Toggle between wireframe and rendering 
of beams and plates 

 

 Joint Labels  
Joint labels toggle 

Toggle the joint labels  

  Beam Labels  
Beam labels toggle 

Toggle the beam labels  

 Member Color Basis  

Member color display toggle 

Member color display toggle  

 Plate Contours  

Show Plate Contours-Forces 

Toggles on the display of the plate 
force/stress contours 

 

 Design Strips  

Show Design Strips 

Toggles on the display of the design strips  

 Pile Caps  

Show Pile Caps 

Toggles on the display of the pile caps  
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 Soil Regions  

Show Soil Regions 

Toggles on the display of the soil regions  

 Show Retaining Wall  Toggles the retaining wall rendered 
display options 

 

 Deflected Diagram  

Show Deflected Diagram 

Toggles on the display of the deflected 
shape 

 

 Distance Tool  

Distance Tool 

Accesses the distance tool- Click two 
points and the distance between them will 
display in the Status Bar 

F5 

 

 

…in Spreadsheet View 

 

Button Title Label in RISAFoundation Shortcut 

 New Line  
Insert a new line before the 
current line  

Insert a new line before the 
current line  

F3 

 Delete Line  
Delete the current line  

Delete the current line  F4 

 Repeat Line  

Repeat the current line 

Repeat the current line F8 

 Sort  

 

Sort based off the 
information in the current 
column 

F9 

 Find  
Find an item F5 

 Fill  
Fill the currently marked 
block  

Fill the currently marked 
block  

Ctrl+F 

 Math  
Perform math on the 
currently marked block  

Perform math on the 
currently marked block  

Ctrl+M 

 Mark Lines  
Mark all the lines 

Mark all the lines  
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 Delete Lines  
Delete the currently marked 
lines  

Delete the currently marked 
lines  

Ctrl+D 

 Unmark Lines  
Unmark all the lines 

UnMark all the lines  Ctrl+L 

 Paste  
Paste from the clipboard  

Paste from the clipboard  Ctrl+V 

 Save as Defaults  

Save the current data as the 
default 

Save the current data as the 
default 

 

 Help 
Help on the current window  

Help for the current 
window  

SHIFT+F1 
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Drawing Toolbar 

 

 

Button Title Label in RISAFoundation Shortcut 

 Draw or Modify Slabs  Draw or modify slabs  

 Create a Slab from Template  
Create a circular slab from 
template 

 

 Draw or Modify Beams  Draw or modify beams  

 Draw or Modify Soil Regions  
Draw or modify soil regions  

 Assign Footings/Supports/Piles  Assign footings and supports  

 Draw or Modify Pedestals  Draw or modify pedestals  

 Draw Wall Footings  Draw or modify wall footings  

 Draw Point Loads  Draw point loads  

 Draw Line Loads  
Draw line loads point to point 

Draw line loads point to point  

 Draw Area Loads  Draw area loads  

 
Draw Slab Openings/ Modify Slab 

Thickness  

Draw openings in your slab or 
adjust the thickness 

 

 Offset Slab Edge  
Modify the slab edge using 
offsets 

 

 Project Grid  

Draw Project Grid Lines 

Draw Project Grid Lins  

 Copy  
Copy selected parts of the 
model 

 

 Delete  
Delete parts of the model 

Delete parts of the model  
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 Modify Drawing Grid  
Modify the drawing grid and snap 
points 

Modify the drawing grid and 
snap points 

 

 Drawing Grid  

Toggle the drawing grid on or off 

Toggle the drawing grid on or 
off 

 

 Universal Snap Points  
Toggle the universal snap points on 
or off 

Toggle the universal snap 
points on or off 

 

 

Selection Toolbar 

 

 

Button Title Label in RISAFoundation Shortcut 

 Select All  
Select the entire model 

Make the entire model 
selected  

CTRL+A 

 Box Select  
Draw a box around the part to 
be selected 

Draw a box around the 
part of the model to be 
selected 

 

 Polygon Select  
Draw a polygon around the part 
to be selected (double click to 
end) 

Draw a polygon around 
the part to be selected 
(double click to end) 

 

 Line Select  
Draw a line through the beams 
and plates to be selected 

Draw a line through the 
beams and plates to be 
selected 

 

 Unselect All  
Unselect the entire model 

Make the entire model 
UNselected  

Ctrl+U 

 Box Unselect  
Draw a box around the part to 
be unselected 

Draw a box around the 
part of the model to be 
UNselected 

 

 Polygon Unselect  
Draw a polygon around the part 
to be unselected (double click to 
end) 

Draw a polygon around 
the part to be UNselected 
(double click to end) 
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  Line Unselect  
Draw a line through the beams 
and plates to be unselected 

Draw a line through the 
beams and plates to be 
UNselected 

 

  Invert Selected  
Invert the selected areas of the 
model 

Invert the selected state 
of the model  

Ctrl+I 

 Criteria Selection  
Select or unselect  

Select or Unselect based 
on other criteria 

 

 Save/Recall Selection  
Save or recall selections of the 
model 

Save or recall selection 
states for the model 

 

 Lock Unselected  
  
 

Lock the unselected part 
of the model  

Ctrl+L 


